This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290331 - epel7 netcdf-fortran FTBFS on aarch64
epel7 netcdf-fortran FTBFS on aarch64
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: netcdf-fortran (Show other bugs)
epel7
aarch64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7aarch64
  Show dependency treegraph
 
Reported: 2015-12-10 04:14 EST by Yaakov Selkowitz
Modified: 2015-12-28 16:25 EST (History)
3 users (show)

See Also:
Fixed In Version: netcdf-fortran-4.2-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 16:25:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-10 04:14:08 EST
The build of netcdf-fortran on the new aarch64 and ppc64le architectures was fixed in Fedora after epel7 branched.  Please merge from at least 1b3d4df and update in order to fix the epel7 builds as well.
Comment 1 Peter Robinson 2015-12-10 04:20:14 EST
it builds just fine on ppc64le, are you sure?

http://koji.fedoraproject.org/koji/buildinfo?buildID=496696
Comment 2 Yaakov Selkowitz 2015-12-10 04:43:56 EST
(In reply to Peter Robinson from comment #1)
> it builds just fine on ppc64le, are you sure?

It certainly does not on aarch64, and the commit in question (which was yours) indicates that it is for both arches.

In any case, since it somehow managed to build on ppc64le but not aarch64, adjusting the BZ accordingly.
Comment 3 Peter Robinson 2015-12-10 04:50:50 EST
> In any case, since it somehow managed to build on ppc64le but not aarch64,
> adjusting the BZ accordingly.

are you sure that's correct, the fix I put in (copying the config.* files) has been mitigated with the addition of it happening as part of the %configure macro so actually is now obsolete as of 7.1 so I actually believe aarch64 is OK too.
Comment 4 Yaakov Selkowitz 2015-12-10 05:12:06 EST
Peter Robinson from comment #3)
> > In any case, since it somehow managed to build on ppc64le but not aarch64,
> > adjusting the BZ accordingly.
> 
> are you sure that's correct, the fix I put in (copying the config.* files)
> has been mitigated with the addition of it happening as part of the
> %configure macro so actually is now obsolete as of 7.1 so I actually believe
> aarch64 is OK too.

It has not mitigated because %configure only replaces config.* under the directory from which it is called, and netcdf-fortran uses a VPATH build.  The bundled config.sub does include powerpc64le, but not aarch64, and for that reason a local build on the latter fails and updating config.* fixes it.
Comment 5 Fedora Update System 2015-12-10 13:05:39 EST
netcdf-4.3.3.1-5.el7 netcdf-fortran-4.2-16.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-215b4baa77
Comment 6 Fedora Update System 2015-12-12 15:23:10 EST
hdf5-1.8.12-7.el7, netcdf-4.3.3.1-5.el7, netcdf-fortran-4.2-16.el7, paraview-4.4.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update paraview hdf5 netcdf-fortran netcdf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-215b4baa77
Comment 7 Fedora Update System 2015-12-28 16:25:40 EST
hdf5-1.8.12-7.el7, netcdf-4.3.3.1-5.el7, netcdf-fortran-4.2-16.el7, paraview-4.4.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.