Bug 1290356 - Engine requires bridge 'rhevm' (should be ovirtmgmnt')
Engine requires bridge 'rhevm' (should be ovirtmgmnt')
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.1.2
All All
unspecified Severity high (vote)
: ---
: ---
Assigned To: Yevgeny Zaspitsky
Lukas Svaty
network
:
Depends On:
Blocks: RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2015-12-10 05:21 EST by Lukas Svaty
Modified: 2016-02-10 14:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 07:27:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
lsvaty: devel_ack?
lsvaty: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2015-12-10 05:21:04 EST
Description of problem:
In latest snapshot engine again requires bridge 'rhevm' to connect to hosts, this was changed in 3.6 to 'ovirtmgmnt' and should persist between new 3.6.x versions

Version-Release number of selected component (if applicable):
rhevm-3.6.1.2-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Have olded snapshot of 3.6
2. Upgrade engine to latest 3.6


Actual results:
Host are non-operational as we need to change bridge 'ovirtmgmnt' to bridge 'rhevm'

Expected results:
Host connection available via bridge 'ovirtmgmnt'

Additional info:
2015-12-10 11:11:44,999 ERROR [org.ovirt.engine.core.bll.SetNonOperationalVdsCommand] (DefaultQuartzScheduler_Worker-63) [44810b4e] Host 'test' is set to Non-Operational, it is missing the following networks: 'rhevm'
Comment 1 Dan Kenigsberg 2015-12-15 06:44:15 EST
Which 3.6 version did you upgrade from?
Could it be that you started with a 3.5 version?

When did you add your hosts to your Engine? Which Vdsm version are they running? Did they ever appear as operational?

Have you tried it more than once? (if not, the 100% figure is misleading)
Comment 2 Lukas Svaty 2015-12-15 07:12:09 EST
I upgraded fresh installation of 3.5 engine. (No hosts in it)
Added hosts that were in previous installation of RHEVM3.6 (another older engine).
They appeared as non-operational as they did not have correct bridge configured.

Tried it on every minor version upgrade as hosts still have the same bridge. This seemes like host installation is creating bridge *rhevm* and reqiures it for host connectivity <- shouldn't that be ovirtmgmnt since 3.6?

vdsm-4.17.13-1.el7ev.noarch

Resolution here:
If we decided to move on 3.6 to use bridge *ovirtmgmnt* this needs fix.
If we are keeping the old *rhevm* bridge for 3.6, closed as NOTABUG
Comment 3 Dan Kenigsberg 2015-12-15 07:27:40 EST
We decided to move to ovirtmgmt for fresh 3.6 installations. Upgrades from 3.5 has 'rhevm' as the default. You can (and should) add a new cluster with ovirtmgmt as its management network.

Note You need to log in before you can comment on or make changes to this bug.