Bug 1290359 - Inconsistency in 'friendly name' field name for Operating System via CLI/API/UI
Inconsistency in 'friendly name' field name for Operating System via CLI/API/UI
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.5
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged, UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 05:27 EST by Andrii Balakhtar
Modified: 2017-03-30 14:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-30 14:36:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrii Balakhtar 2015-12-10 05:27:26 EST
Description of problem:
'Friendly name' field (which is name + major version + minor version) for Operating System is called, documented and acts differently for each interface (UI/CLI/API).
For UI, list of OSs is shown under 'Title' column. When you open any OS - there's no 'Title' field to change. There's 'Description' field instead, which is empty by default (meaning that's another field actually), but changing that description actually changes OS title.
Next, for CLI, 'hammer os create' command accepts '--description' (not --title) option. However, 'hammer os info' accepts and returns --title instead. Other commands like 'hammer medium add-operatingsystem' work with OS title, not description, too.
For API, apidoc contains no information about 'title' field, there's only 'description'. However, when you try to GET any custom OS, you'll see 'title' in output, which is representing OS friendly name, and 'description' field too, which is set to null by default.
Looks like there was no clear agreement on how the field should be called - in some places it's 'title', in others its 'description'. Both fields share same purpose so one of them (preferably 'description') should be dropped in favor of another.


Version-Release number of selected component (if applicable):
6.1.5C2, RHEL7.2

How reproducible:
Always.

Steps to Reproduce:
1. Create Operating system (via UI/CLI/API, doesn't matter), do not specify anything in 'title'/'description' field.
2. Check 'title'/'description' via UI/CLI/API.

Actual results:
See 'Description of problem'

Expected results:
Leave only 'title' field for all three interfaces.

Additional info:
Comment 2 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Bryan Kearney 2016-07-26 11:38:05 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Bryan Kearney 2017-03-30 14:36:47 EDT
Thank you for your bug report. Given our other priorities, I do not see us addressing this in the next few releases. I am therefore closing this out. If you feel that this is a mistake, please feel free to re-open with additional information. Thank you for your interest in Red Hat Satellite.

Note You need to log in before you can comment on or make changes to this bug.