Bug 1290390 - Stray -nv in wget manpage
Stray -nv in wget manpage
Status: CLOSED DUPLICATE of bug 1147572
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: wget (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Hozza
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 06:51 EST by Phil Sutter
Modified: 2015-12-10 07:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 07:07:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Sutter 2015-12-10 06:51:22 EST
Seen with wget-1.14-10.el7_0.1.x86_64:


/usr/share/man/man1/wget.1.gz, line 323ff:

.IP "\fB\-nv\fR" 4
.IX Item "-nv"
.PD 0
.IP "\fB\-\-no\-verbose\fR" 4
.IX Item "--no-verbose"
.PD
Turn off verbose without being completely quiet (use \fB\-q\fR for
that), which means that error messages and basic information still get
printed.
.IP "\fB\-nv\fR" 4
.IX Item "-nv"
.PD 0
.IP "\fB\-\-report\-speed=\fR\fItype\fR" 4
.IX Item "--report-speed=type"
.PD
Output bandwidth as \fItype\fR.  The only accepted value is \fBbits\fR.

Short option '-nv' is listed twice, the second time incorrectly as alternative to long option '--report-speed'.
Comment 1 Tomáš Hozza 2015-12-10 07:07:32 EST

*** This bug has been marked as a duplicate of bug 1147572 ***
Comment 2 Phil Sutter 2015-12-10 07:16:34 EST
Duh, sorry! I'm obviously too stupid to search BZ - using 'wget -nv' did not suffice.
Comment 3 Jan Chaloupka 2015-12-10 07:18:23 EST
Hi Phil,

can you run 'rpm -q man-pages-overrides' and post its output?

In order to get the latest fixes of man pages applied, man-pages-overrides package must be installed and the latest.

Thanks
Jan
Comment 4 Phil Sutter 2015-12-10 07:32:25 EST
Hi Jan,

(In reply to Jan Chaloupka from comment #3)
> can you run 'rpm -q man-pages-overrides' and post its output?
> 
> In order to get the latest fixes of man pages applied, man-pages-overrides
> package must be installed and the latest.

Indeed, man-pages-overrides wasn't installed. Maybe that should become part of the default installation (although I don't remember what exact options I chose when installing that VM). After installing man-pages-overrides-7.2.4-1.el7 with yum, wget.1 appears to be correct!

Thanks, Phil

Note You need to log in before you can comment on or make changes to this bug.