Bug 1290404 - wrong names of components in man page, section SEE ALSO
wrong names of components in man page, section SEE ALSO
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: squid (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Luboš Uhliarik
Jan Houska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 07:54 EST by Ondřej Pták
Modified: 2017-08-01 17:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: squid-3.5.20-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 17:35:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondřej Pták 2015-12-10 07:54:05 EST
Description of problem:
In squid man page, section SEE ALSO, there are several man pages with wrong name.

Version-Release number of selected component (if applicable):
squid-3.3.8-26.el7

How reproducible:
always

Steps to Reproduce:
1. man squid  # see section SEE ALSO

Actual results:
SEE ALSO
       cachemgr.cgi  (8),  squidclient (1), pam_auth (8), squid_ldap_auth (8),
       squid_ldap_group (8), ext_session_acl (8), squid_unix_group (8),

Expected results:
SEE ALSO
       cachemgr.cgi  (8),  squidclient (1), basic_pam_auth (8), basic_ldap_auth (8),
       ext_ldap_group_acl (8), ext_unix_group_acl (8), 


Additional info:
No manual entry for pam_auth
No manual entry for squid_ldap_auth
No manual entry for squid_ldap_group
No manual entry for squid_unix_group

Thera are more man pages, should't some of them be also metion (list of all man pages)?

squidclient (1)
basic_db_auth (8)
basic_getpwnam_auth (8)
basic_ldap_auth (8)
basic_ncsa_auth (8)
basic_pam_auth (8)
basic_radius_auth (8)
basic_sasl_auth (8)
cachemgr.cgi (8)
digest_file_auth (8)
ext_file_userip_acl (8)
ext_ldap_group_acl (8)
ext_session_acl (8)
ext_time_quota_acl (8)
ext_unix_group_acl (8)
ext_wbinfo_group_acl (8)
log_db_daemon (8)
negotiate_kerberos_auth (8)
squid (8)
Comment 6 Jan Houska 2017-05-08 14:23:35 EDT
Verified:

Contend of 'man squid' section "SEE ALSO" in new version(squid-3.5.20-10.el7.) is now: 
"""
SEE ALSO
       cachemgr.cgi   (8),  squidclient  (1),  basic_pam_auth  (8),  basic_ldap_auth  (8),
       ext_ldap_group_acl (8), ext_session_acl (8), ext_unix_group_acl (8),
       The Squid FAQ wiki http://wiki.squid-cache.org/SquidFaq
       The Squid Configuration Manual http://www.squid-cache.org/Doc/config/
"""


Old version (squid-3.3.8-26.el7) contained: 
"""
SEE ALSO
       cachemgr.cgi   (8),   squidclient   (1),   pam_auth   (8),   squid_ldap_auth   (8),
       squid_ldap_group (8), ext_session_acl (8), squid_unix_group (8),
       The Squid FAQ wiki http://wiki.squid-cache.org/SquidFaq
       The Squid Configuration Manual http://www.squid-cache.org/Doc/config/
"""

The new version seems sane.
Comment 7 errata-xmlrpc 2017-08-01 17:35:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2174

Note You need to log in before you can comment on or make changes to this bug.