Bug 1290411 - Improve docs for Content View filters and versions
Improve docs for Content View filters and versions
Status: CLOSED DUPLICATE of bug 1153650
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
6.1.4
Unspecified Unspecified
medium Severity low (vote)
: GA
: 6.2
Assigned To: Dan Macpherson
satellite-doc-list
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 08:05 EST by Stephen Wadeley
Modified: 2016-07-05 22:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 22:50:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Wadeley 2015-12-10 08:05:35 EST
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-Using_Content_Views-Filtering_Content.html 

Red_Hat_Satellite-User_Guide-6.1-en-US-2-4

Section Number and Name: 

"Filtering Content"

Describe the issue: 

Currently there is no explanation as to how the Content View filters are parsed. There doesn't appear to be a method in the UI to order the Content View filters, so are they parsed in the order they are added? or are exclude filters parsed before include or vice-versa? How are conflicts in rules resolved? Is it suggested that include/exclude filters not be mixed in the same Content view? 


There also isn't any discussion in the documentation with regard to Content View versions and their relationships. Is version 2.0 inclusive of version 1.0 content? or is it a completely different instance of the content so all filters must be redefined? (Diagram figure 6.1 doesn't make this clear).

Can the documentation also possibly include a description as to why a Composite Content View can't contain content from two different Content Views if they contain the same repository? This seems like an artificial constraint.

Additional information: 

Source: https://access.redhat.com/discussions/1987953#comment-995113
Comment 1 Stephen Wadeley 2015-12-10 09:52:51 EST
(In reply to Stephen Wadeley from comment #0)
> Document URL: 
> 
> https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/
> User_Guide/sect-Red_Hat_Satellite-User_Guide-Using_Content_Views-
> Filtering_Content.html 
> 
> Red_Hat_Satellite-User_Guide-6.1-en-US-2-4
> 
> Section Number and Name: 
> 
> "Filtering Content"
> 
> Describe the issue: 
> 
> Currently there is no explanation as to how the Content View filters are
> parsed. There doesn't appear to be a method in the UI to order the Content
> View filters, so are they parsed in the order they are added? or are exclude
> filters parsed before include or vice-versa? How are conflicts in rules
> resolved? Is it suggested that include/exclude filters not be mixed in the
> same Content view? 

This seems to be already requested here:
Bug 1153650 - Content view filtering process not documented


> 
> 
> There also isn't any discussion in the documentation with regard to Content
> View versions and their relationships. Is version 2.0 inclusive of version
> 1.0 content? or is it a completely different instance of the content so all
> filters must be redefined? (Diagram figure 6.1 doesn't make this clear).


This seems to be already requested here:
Bug 1203939 - Content Views documentation not clear on the relationship between versions and hosts


> 
> Can the documentation also possibly include a description as to why a
> Composite Content View can't contain content from two different Content
> Views if they contain the same repository? This seems like an artificial
> constraint.
> 
> Additional information: 
> 
> Source: https://access.redhat.com/discussions/1987953#comment-995113
Comment 2 Dan Macpherson 2016-07-05 22:50:18 EDT

*** This bug has been marked as a duplicate of bug 1153650 ***

Note You need to log in before you can comment on or make changes to this bug.