Bug 1290421 - changelog: CHANGELOG rename error is logged on every changelog rollover
changelog: CHANGELOG rename error is logged on every changelog rollover
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: changelog (Show other bugs)
mainline
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 08:18 EST by Kotresh HR
Modified: 2016-06-16 09:50 EDT (History)
0 users

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2015-12-10 08:18:07 EST
Description of problem:
On gluster volume, when changelog is enabled, the following misleading error is logged where there is no actual failure.

[2015-12-10 12:38:58.513876] E [MSGID: 117004] [changelog-helpers.c:482:changelog_rollover_changelog] 0-master-changelog: error renaming /bricks/brick0/b0/.glusterfs/changelogs/CHANGELOG -> /bricks/brick0/b0/.glusterfs/changelogs/CHANGELOG.1449751138


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Create gluster volume
2. Enable changelog 
3. Mount volume, touch a file and wait for changelog rollover time (15 sec)

Actual results:
Even if changelog rename is successful, error is logged.

Expected results:
When rename is successful, error should not be logged.

Additional info:
Comment 1 Vijay Bellur 2015-12-10 08:29:41 EST
REVIEW: http://review.gluster.org/12940 (features/changelog: Remove incorrect error message) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 2 Vijay Bellur 2015-12-14 22:41:30 EST
COMMIT: http://review.gluster.org/12940 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit be438f9aa70cce9d14d72d7cf8ddee89738db36c
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Dec 10 18:53:37 2015 +0530

    features/changelog: Remove incorrect error message
    
    During changelog_rollover, the rename error is
    logged even though changelog rollover is successful.
    This got mistakenly added as part of commit
    64e6836ac8fb96f38a859eea0d8525cd9bd2693f
    (http://review.gluster.org/10532). Removing the
    same.
    
    Change-Id: I7ac1a16b41de5a6a4d7e714946585dff3ce0e83b
    BUG: 1290421
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12940
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Niels de Vos 2016-06-16 09:50:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.