Bug 1290427 - snapshot without disks gets deleted automatically once a snapshot gets commited
snapshot without disks gets deleted automatically once a snapshot gets commited
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.5.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Maor
Kevin Alon Goldblatt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 08:33 EST by Maor
Modified: 2016-08-01 08:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 08:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 58088 master ABANDONED core: Add parent snapshot id to snapshots table. 2016-06-01 12:51 EDT
oVirt gerrit 58550 master MERGED core: Handle snapshot entity instead of snapshot id. 2016-06-06 08:59 EDT
oVirt gerrit 58551 master MERGED core: Validate creation date is bigger then deleted snapshot. 2016-06-06 09:00 EDT
oVirt gerrit 58673 ovirt-engine-4.0 MERGED core: Handle snapshot entity instead of snapshot id. 2016-06-06 12:07 EDT
oVirt gerrit 58674 ovirt-engine-4.0 MERGED core: Validate creation date is bigger then deleted snapshot. 2016-06-06 12:07 EDT

  None (edit)
Description Maor 2015-12-10 08:33:51 EST
Description of problem:
previewing a snapshot without any disks and committing it will cause the earlier snapshots to get deleted, although they might contain VM configuration data.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a VM with image disk
2. Create a snapshot containing this disk
3. Create another snapshot without this disk
4. Try to preview the last snapshot (The one without the disk)
5. commit the snapshot

Actual results:
The first snapshot gets deleted

Expected results:
The first snapshot should not get deleted since it is also containing the VM's configuration

Additional info:
Comment 1 Maor 2015-12-23 04:47:25 EST
The origin of this bug is that the hierarchy of snapshots is defined by the images and not the snapshots table.
The fix for that should be to define parent and child also for snapshots and maybe neglect the use of images hierarchy to be used for commit and preview.
Since this behavior reflects a big change that needs to be tested with all the relevant scenarios, and this bug is a small use case of snapshots without disks.
I'm changing the target to 4.0
Comment 2 Red Hat Bugzilla Rules Engine 2015-12-23 04:47:29 EST
This bug is marked for z-stream, yet the milestone is for a major version, therefore the milestone has been reset.
Please set the correct milestone or drop the z stream flag.
Comment 3 Sandro Bonazzola 2016-05-02 06:02:43 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Yaniv Lavi 2016-05-23 09:17:58 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Yaniv Lavi 2016-05-23 09:21:57 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 Kevin Alon Goldblatt 2016-07-14 04:30:01 EDT
Verified with the following code:
---------------------------------------
vdsm-4.18.4-2.el7ev.x86_64
rhevm-4.0.2-0.2.rc1.el7ev.noarch

Verified using the following scenario:
---------------------------------------
1. Create a VM with image disk
2. Create a snapshot containing this disk
3. Create another snapshot without this disk
4. Try to preview the last snapshot (The one without the disk)
5. commit the snapshot

Actual results:
The first snapshot remains in tact


Moving to VERIFIED!

Note You need to log in before you can comment on or make changes to this bug.