Bug 1290446 - upgrade of GNOME Desktop to rhel7.2 breaks GUI
upgrade of GNOME Desktop to rhel7.2 breaks GUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-12-10 09:33 EST by Ashish Shah
Modified: 2016-11-03 21:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:42:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum logs captured from my local reproducer (14.83 KB, text/plain)
2015-12-10 09:33 EST, Ashish Shah
no flags Details

  None (edit)
Description Ashish Shah 2015-12-10 09:33:40 EST
Created attachment 1104367 [details]
yum logs captured from my local reproducer

Description of problem:

Upgrade of gnome desktop from rhel7.1 to rhel7.2 does not take all the packages to next level and GUI breaks
Blank screen is observe upon reboot after running update

Version-Release number of selected component (if applicable):
rhel7.1 to rhel7.2 update

How reproducible:
Always

Steps to Reproduce:
1. Fresh install rhel7.1
2. Register and upgrade gnome to current (rhel7.2) level
 yum groupupdate "GNOME Desktop"
3. reboot

Actual results:
Blank screen

Expected results:
Gnome should be updated correctly and login screen should be presented after reboot


Additional info:
Below steps helps to update system correctly..
yum deplist gnome-shell | grep provider | awk -F: '{print $2}'| awk '{print $1}' > list
cat  list | sort -n | uniq > list.new
yum update `cat list.new`

I am not sure which component to be blamed for this behaviour. I have marked this bug against gnome-shell for now. Please correct this if not appropriate.
Comment 3 Ashish Shah 2015-12-15 04:49:40 EST
Below command helps to recognise "X Window System" group for update..
 yum groups mark convert "X Window System"

Checking by upgrading gnome and Xorg related groups
Comment 4 Ashish Shah 2015-12-15 05:58:50 EST
Including "X Window system" in groupupdate didn't help.
Need to run below command to get system up in GUI mode..

yum update `yum deplist gnome-shell | grep provider | awk -F: '{print $2}'| awk '{print $1}' | sort -n | uniq`
Comment 6 Florian Müllner 2015-12-16 13:44:22 EST
(In reply to Ashish Shah from comment #4)
> yum update `yum deplist gnome-shell | grep provider | awk -F: '{print $2}'|
> awk '{print $1}' | sort -n | uniq`

As this fixes the issue(*), the dependencies in the RPM are correct, however for some reason "yum groupupdate" misses them. I'm not too familiar with package groups, so this might be the expected behavior and all dependencies need to be added to the relevant groups, but in any case it looks like the fix is not in gnome-shell. Reassigning to yum, whose maintainers hopefully have a better idea whether this should be addressed in yum or comps (or whatever I am missing).


(*) although we miss to update gnome-classic-session and dependencies, so we probably want that in the "GNOME Desktop" group as well
Comment 7 Karel Srot 2015-12-17 06:27:13 EST
What packages are needed but missing after the update so the desktop doesn't work? Shouldn't this be all ensured through package dependencies?
Comment 13 Matthias Clasen 2016-01-11 15:59:16 EST
I am not sure I understand what the problem in comment 10 is that would be fixed in the gnome-shell rpm.

gnome-shell has indirect library dependencies on libXi and gstreamer1 - are you saying that is not enough to ensure that these packages are included in the update ?

What is the suggested fix here ?
Comment 14 Karel Srot 2016-01-12 01:33:45 EST
(In reply to Matthias Clasen from comment #13)
> gnome-shell has indirect library dependencies on libXi and gstreamer1 - are
> you saying that is not enough to ensure that these packages are included in
> the update ?

#c10 clearly proves that the new version of gstreamer1 and libXi is needed in order to make the desktop work properly. gnome-shell could have indirect library dependency but without specifying the necessary minimal version.

> What is the suggested fix here ?

As stated in #c10:
 "Simply gnome-shell or another package should require newer version of those packages"
Comment 15 Karel Srot 2016-01-12 01:36:42 EST
Just for an information, pasting the workaround publicly:

In order to restore proper desktop functionality following two packages need to be updated to new versions:
  gstreamer1 (gstreamer1-1.4.5-1.el7.x86_64)
  libXi (libXi-1.7.4-2.el7.x86_64)
Comment 16 Karel Srot 2016-01-12 01:46:41 EST
(In reply to Karel Srot from comment #14)
> (In reply to Matthias Clasen from comment #13)
> > gnome-shell has indirect library dependencies on libXi and gstreamer1 - are
> > you saying that is not enough to ensure that these packages are included in
> > the update ?

Just an additional note... Please note the in the described scenario only GNOME and "X Window System" package groups are being updated. As neither gstreamer1 nor libXi are part of the group, yum has no reason to update them (as there is no explicit dependency on new versions). 
If gnome-shell doesn't work properly with old versions of gstreamer1 and libXi, it has to depend on (either indirectly) new versions.
Comment 17 Matthias Clasen 2016-01-12 09:17:55 EST
thanks for the clarification
Comment 18 Florian Müllner 2016-03-04 10:43:19 EST
Addressed in clutter-1.20.0-5.el7 and gnome-shell-3.14.4-38.el7.
Comment 22 errata-xmlrpc 2016-11-03 21:42:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html

Note You need to log in before you can comment on or make changes to this bug.