Bug 1290448 - mutter is changing monitor layout from that set by xorg.conf
Summary: mutter is changing monitor layout from that set by xorg.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
: 1302941 (view as bug list)
Depends On:
Blocks: 1203710 1297830 1313485
TreeView+ depends on / blocked
 
Reported: 2015-12-10 14:36 UTC by Alan Matsuoka
Modified: 2019-12-16 05:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:42:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport (9.97 MB, application/x-xz)
2015-12-10 14:41 UTC, Alan Matsuoka
no flags Details
monitors.xml (1.74 KB, text/plain)
2015-12-10 14:41 UTC, Alan Matsuoka
no flags Details
monitors-dconf.png (61.82 KB, image/png)
2015-12-10 14:42 UTC, Alan Matsuoka
no flags Details
xorg.conf (9.99 KB, text/plain)
2015-12-10 14:42 UTC, Alan Matsuoka
no flags Details
Xorg.0.log (81.29 KB, text/plain)
2015-12-10 14:43 UTC, Alan Matsuoka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2258 0 normal SHIPPED_LIVE gnome-shell, gnome-shell-extensions, and gtk3 bug fix and enhancement update 2016-11-03 13:32:13 UTC

Description Alan Matsuoka 2015-12-10 14:36:47 UTC
Description of problem:
We have set a specific monitor layout in xorg.conf with 4 displays using Nvidia's metamodes (see attached xorg.conf). If you just start the Xorg process the monitor layout is correct. In this particular case monitor 1+3 are overlapped and 2+4 are overlapped. When gnome-shell is started and the gnome-settings-daemon runs, it changes the orientation around (lining up the displays). This occurs on a fresh installation where no user has ever logged in, so the login screen layout is not correct.  See the layout changing in the Xorg.0.log file. 

I have tried creating a monitors.xml file (see attached) and placing it in /var/lib/gdm/.config and this corrects the login screen, but once a user logs in the layout is once again changed. 

Where can I set a default layout or how can I get gnome-settings-daemon xrandr to stop changing the layout defined in xorg.conf? I've tried placing a monitors.xml file in /etc/gnome-settings-daemon/xrandr but that had no affect.

On a related note, the gnome-control-center display settings applet does not support overlapping displays (i.e. cloning groups of displays). It only allows cloning all displays. There are cases were we need to clone only certain displays. Can you create an RFE for this feature?


Version-Release number of selected component (if applicable):

gnome-settings-daemon-3.14.4-9.el7

How reproducible:
RHEL 7.2  with Nvidia Quadro M5000/M6000 and driver 352.63 with 4 displays attached over display port.

Steps to Reproduce:
1.
2.
3.

Actual results:
I tried changing the default to /etc/gnome-settings-daemon/monitors.xml and
placing the file there but that didn't help. If I copy the same
monitors.xml file to ~/.config/monitors.xml then my layout is correct, but
that's not something we can do in general for users.

Expected results:
CU has a specific monitor layout in xorg.conf with 4 displays using Nvidia's metamodes (see attached xorg.conf). If you just start the Xorg process the monitor layout is correct. In this particular case monitor 1+3 are overlapped and 2+4 are overlapped. When gnome-shell is started and the gnome-settings-daemon runs, it changes the orientation around (lining up the displays). This occurs on a fresh installation where no user has ever logged in, so the login screen layout is not correct.

They have tried placing a monitors.xml file in /etc/gnome-settings-daemon/xrandr but seems to work sometimes and other times not, it's inconsistent.

Where can they set a default layout or how can they get gnome-settings-daemon xrandr to stop changing the layout defined in xorg.conf? 


Additional info:
I did some more testing, and it appear that some times it reads the default from /etc/gnome-settings-daemon/xrandr/monitors.xml and some times it doesn't, but even when it does the geometry of the workspace is set to the equivalent of the 4 linear displays (or some times 3) even though 2 of the displays are overlapping so you end up with a large panning area.  It seems very inconsistent. 

If we can get this working correctly I'd be happy, but at the same time, requiring a monitors.xml makes is more difficult to set up a default if it is going to depend on specific monitors and serial numbers as hardware gets swapped in and out on a regular basis. I'd much rather it honor the layout defined in xorg.conf.

Comment 1 Alan Matsuoka 2015-12-10 14:41:01 UTC
Created attachment 1104368 [details]
sosreport

Comment 2 Alan Matsuoka 2015-12-10 14:41:42 UTC
Created attachment 1104369 [details]
monitors.xml

Comment 3 Alan Matsuoka 2015-12-10 14:42:12 UTC
Created attachment 1104370 [details]
monitors-dconf.png

Comment 4 Alan Matsuoka 2015-12-10 14:42:41 UTC
Created attachment 1104371 [details]
xorg.conf

Comment 5 Alan Matsuoka 2015-12-10 14:43:05 UTC
Created attachment 1104372 [details]
Xorg.0.log

Comment 6 Bastien Nocera 2016-01-12 18:29:18 UTC
Reassigning to mutter as it's the one that's realigning the outputs on startup. If anything, it would be the one providing the setting to "not touch the monitor configuration".

As for supporting cloned groups of monitors, this is probably not something that we'd be interested in supporting in the configuration tool, but you can still file a bug, either here or upstream, explaining how or why this is an important feature to have available (rather than a one-off configuration which you can use once the above bug is fixed).

Comment 18 Bastien Nocera 2016-05-24 09:54:56 UTC
*** Bug 1302941 has been marked as a duplicate of this bug. ***

Comment 32 errata-xmlrpc 2016-11-04 01:42:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html


Note You need to log in before you can comment on or make changes to this bug.