Bug 1290458 - Update Pacemaker doc with 6.8 rebase info
Update Pacemaker doc with 6.8 rebase info
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Cluster_General (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
Steven J. Levine
: Documentation, Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 10:09 EST by Steven J. Levine
Modified: 2017-03-22 14:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
New Pacemaker features The Red Hat Enterprise Linux 6.8 release supports the following Pacemaker features: * You can now use the "pcs resource relocate run" command to move a resource to its preferred node, as determined by current cluster status, constraints, location of resources and other settings. * When configuring fencing for redundant power supplies, you now are only required to define each device once and to specify that both devices are required to fence the node. * The new `resource-discovery` location constraint option allows you to indicate whether Pacemaker should perform resource discovery on a node for a specified resource. * Resources will now start as soon as their state has been confirmed on all nodes and all dependencies have been satisfied, rather than waiting for the state of all resources to be confirmed. This allows for faster startup of some services, and more even startup load. * Clone resources support a new `clone-min` metadata option, specifying that a certain number of instances must be running before any dependent resources can run. This is particularly useful for services behind a virtual IP and haproxy, as is often done with OpenStack. These features are documented in "Configuring the Red Hat High Availability Add-On with Pacemaker", available at https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Configuring_the_Red_Hat_High_Availability_Add-On_with_Pacemaker/index.html.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-22 14:55:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2015-12-10 10:09:01 EST
From Ken Gaillot:

I plan to rebase pacemaker in 6.8 in another week or so, which means
that it will have everything that went into 7.2, so you can reuse those
docs.

It will be based on pacemaker 1.1.14, which has these new features
(which I think are all in 7.2 already):

   http://clusterlabs.org/pipermail/users/2015-December/001933.html

If you have any questions, don't hesitate to ask.
Comment 1 Steven J. Levine 2016-02-01 15:37:39 EST
Just to put the info here (with comments). I will send a separate email to Ken Gaillot with these questions...

* Resources will now start as soon as their state has been confirmed on
all nodes and all dependencies have been satisfied, rather than waiting
for the state of all resources to be confirmed. This allows for faster
startup of some services, and more even startup load.

COMMENT: Not sure this affects the doc -- no change to the interface. Need to check with Ken.


* Fencing topology levels can now be applied to all nodes whose name
matches a configurable pattern, or that have a configurable node attribute.

COMMENT: I don't think I documented this for RHEL 7.2.  I need to send the section on Configuring Fencing Levels to Ken for an example. For RHEL 7 it is this:

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/High_Availability_Add-On_Reference/s1-fencelevels-HAAR.html

For RHEL 6 it is this:

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Configuring_the_Red_Hat_High_Availability_Add-On_with_Pacemaker/s1-fencelevels-HAAR.html

* When a fencing topology level has multiple devices, reboots are now
automatically mapped to all-off-then-all-on, allowing much simplified
configuration of redundant power supplies.

I think this is the section we added for RHEL 7.2 that we need to add for RHEL 6.8:


http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/High_Availability_Add-On_Reference/s1-redundantfence-HAAR.html

* Guest nodes can now be included in groups, which simplifies the common
Pacemaker Remote use case of a grouping a storage device, filesystem and VM.

I will wholly replace the Pacemaker remote section with the 7.3 draft. I will add a sentence after the instructions for creating a guest node resource 
"As of Red Hat Enterprise Linux 7.3, you can include guest nodes in groups,
which allows you to group a storage device, file system, and VM." For 6.8, I will note 6.8.


* Clone resources have a new clone-min metadata option, specifying that
a certain number of instances must be running before any dependent
resources can run. This is particularly useful for services behind a
virtual IP and haproxy, as is often done with OpenStack.

We don't currently document any metadata options for clone resources. I will ask Ken about this.
Comment 5 Steven J. Levine 2017-03-22 14:55:59 EDT
This update has been on the Portal since RHEL 6.8 so I am closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.