Bug 1290472 - Error loading certificate file containing negative serial number
Error loading certificate file containing negative serial number
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: golang (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Čajka
Martin Cermak
: Extras
Depends On:
Blocks: 1289473
  Show dependency treegraph
 
Reported: 2015-12-10 10:43 EST by Jordan Liggitt
Modified: 2016-11-03 21:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: golang-1.6-1.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: 1289473
: 1290543 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:35:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Liggitt 2015-12-10 10:43:11 EST
Description of problem:
x509 certificates containing negative serial numbers cannot be loaded.

Version-Release number of selected component (if applicable):
go 1.4.x, 1.5.x

How reproducible:
Always

Steps to Reproduce:
1. Create an x509 certificate with a negative serial number
2. Load it using golang's x509.ParseCertificate function

Actual results:
An error is returned

Expected results:
The certificate can be loaded

Additional info:
See https://github.com/golang/go/issues/8265

See http://play.golang.org/p/zpXKadV5mo for recreation
Comment 6 errata-xmlrpc 2016-11-03 21:35:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2245.html

Note You need to log in before you can comment on or make changes to this bug.