Bug 129048 - (IT_49498) new up2date gives 'Invalid group id server-cfg' error
new up2date gives 'Invalid group id server-cfg' error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Beth Nackashi
:
Depends On:
Blocks: 155571 156320
  Show dependency treegraph
 
Reported: 2004-08-03 11:09 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2005-712
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 13:10:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of up2date -uvvv (1.29 KB, text/plain)
2004-08-03 23:40 EDT, Jeff Moore
no flags Details
up2date debug output (9.40 KB, text/plain)
2004-08-04 02:31 EDT, Landon Curt Noll
no flags Details

  None (edit)
Description Need Real Name 2004-08-03 11:09:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; IRIX IP22; en-US; rv:1.6) Gecko/20040505

Description of problem:
After installing the new up2date 4.2.33-1 release with
up2date itself, I am getting an error message...

Invalid group id server-cfg

which didn't appear before. The error doesn't seem to
impact the functionality of up2date.

Version-Release number of selected component (if applicable):
 4.2.33-1

How reproducible:
Always

Steps to Reproduce:
1.use up2date to install up2date 4.2.33-1 on RHEL3WS
2.run 'update -u' from a terminal window as root
    

Actual Results:  I see an new unexpected error message of 'Invalid
group id server-cfg'
although the up2date program appears to still function properly.

Expected Results:  I expected no error messages


Additional info:
Comment 1 Jeff Moore 2004-08-03 23:40:13 EDT
Created attachment 102413 [details]
Output of up2date -uvvv

Per RHGSS request, here's the output of "up2date -uvvv" (except that while they
asked me to do

  up2date -uvvv > 351402.txt

I took the liberty of substituting

  up2date -uvvv >/tmp/351402.txt 2>&1

'cause some things were coming out to stderr.)
Comment 2 Landon Curt Noll 2004-08-04 02:31:57 EDT
Created attachment 102415 [details]
up2date debug output

Perhaps this additional output of the command will help:

up2date -uvvv --nox -d >/var/tmp/up2date.txt 2>&1

showing the "Invalid group id server-cfg" issue.
Comment 3 Christian Hofmann 2004-08-05 04:12:17 EDT
/me got the same problem since the update. Here is my output from EL 
3.0 WS

up2date -uvvv --nox -d  
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: logininfo: {'X-RHN-Auth-Server-Time': '1091692550.04', 'X-RHN-
Auth': 'Wx29GPPVfnzE6HjH+ZF/+Q==', 'X-RHN-Server-Id': 1004488176, 'X-
RHN-Auth-Channels': [['rhel-i386-ws-
3', '20040804175100', '1', '1']], 'X-RHN-Auth-User-
Id': 'chhofman', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: availablePackageList::channels: 
<up2date_client.rhnChannel.rhnChannelList instance at 0x84461ec>
D: add instance class name diskcache
D: add instance class name get
D: listPackages Fetched via: diskcache
Invalid group id server-cfg
D: obsoletesList::channels: <up2date_client.rhnChannel.rhnChannelList 
instance at 0x84461ec>

Fetching Obsoletes list for channel: rhel-i386-ws-3...
D: add instance class name diskcache
D: add instance class name get
D: getObsoletes Fetched via: diskcache

Fetching rpm headers...

Name                                    Version        Rel     
----------------------------------------------------------

All packages are currently up to date
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
Comment 4 Gary Case 2004-08-05 09:53:49 EDT
This bug only affects the WS version of RHEL 3. It bug can be
reproduced on a stock RHEL WS Update 2 box by installing the newest
up2date. 

It appears that the bug is caused by a reference to a non-existent
group in /usr/share/comps/i386/comps.xml. In all three versions of
RHEL, a reference in comps.xml is made to group called "server-cfg".
This group should contain installation information for the
redhat-config-* packages. In WS, the reference to the server-cfg group
is still there but as there are no servers installed with WS, the
actual group itself doesn't exist. This is what's causing the error to
be displayed while running up2date. 

The bug is harmless. It just generates an error message each time
up2date is run. Adrian, I hope this helps. You may want to reassign
this to the comps.xml maintainer, because from what I can see, this
isn't a problem with up2date.
Comment 6 Adrian Likins 2004-08-17 14:40:24 EDT
warning commented out in future versions of up2date,
since its not harmful. 

comps should be fixed as well, so assigning there
Comment 7 Dynamic Net, Inc. 2004-09-07 13:50:32 EDT
The bug is not harmless.

This bug is preventing the update to Taroon 3 because you cannot 
run "up2date --nox --dry-run" to see the Taroon 3 updates.

Thank you.
Comment 8 nathan r. hruby 2004-09-07 14:02:50 EDT
That command seems to work for me....  You sure you have the right bug?
Comment 10 Adrian Likins 2004-09-08 18:55:05 EDT
re #9  

I disagree that the problem isnt in comps.xml. The comps.xml
on WS is incorrect for the packages included with WS.

That said, I don't really care, up2date wont complain
anymore regardless of whats in the comps file, so
it doesnt really matter if whats in them is bogus
or not.  
Comment 13 Adrian Likins 2004-12-10 13:33:10 EST
re comment #7, the warning is harmless. If your
having problems upgrading, it's another bug that
causing the problem. 
Comment 14 David Lehman 2005-01-04 14:51:40 EST
So is this a comps bug or an up2date bug? I notice the warning's commented out
in FC3 up2date, but not in FC2 or RHEL3.

Is there any reason the warning hasn't been removed in RHEL3?
Comment 22 Debbie McGrath 2005-06-08 10:19:04 EDT
This bug is considered MustFix for RHEL 3 U6 by RHN Engineering.
Comment 26 Beth Nackashi 2005-07-01 17:17:05 EDT
retested this bug in the following configuration:
-RHEL 3 WS U5 x86 box registered to RHEL 4 AS satellite
-up2date version up2date-4.4.26-3

output:

[root@test07 tmp]# up2date -uvvv up2date
warning: can't access /etc/sysconfig/rhn/sources
D: availablePackageList::channels: <up2date_client.rhnChannel.rhnChannelList
instance at 0xa13a99c>
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: availablePackageList::channels: <up2date_client.rhnChannel.rhnChannelList
instance at 0xa13a99c>
D: obsoletesList::channels: <up2date_client.rhnChannel.rhnChannelList instance
at 0xa13a99c>

Fetching rpm headers...
D: availablePackageList::channels: <up2date_client.rhnChannel.rhnChannelList
instance at 0xa13a99c>

Name                                    Version        Rel     
----------------------------------------------------------

All packages are currently up to date
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages

Note:  The /etc/sysconfig/rhn/sources warning is written up in a separate bug
(162071).
Comment 27 Beth Nackashi 2005-07-08 11:16:07 EDT
also tested on ia64, i-series (ppc), p-series (ppc), and z-series (s390x)
Comment 29 Todd Warner 2005-09-23 17:45:06 EDT
PROD_READY is a deprecated state. This bug is now RELEASE_PENDING.
Comment 30 Red Hat Bugzilla 2005-09-28 13:10:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-712.html

Note You need to log in before you can comment on or make changes to this bug.