Bug 1290482 - log: first installation shows git error in evm.log
log: first installation shows git error in evm.log
Status: POST
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.5.6
Assigned To: Nick Carboni
Aziza Karol
appliance:error
: ZStream
Depends On: 1286793
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 11:08 EST by John Prause
Modified: 2016-10-06 17:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286793
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Prause 2015-12-10 11:08:51 EST
+++ This bug was initially created as a clone of Bug #1286793 +++

Description of problem:

after first installation, the below appears in log: 
/opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git/git_proxy.rb:155:in `allowed_in_path': The git source git://github.com/ManageIQ/handsoap.git is not yet checked out. Please run `bundle install` before trying to start your application (Bundler::GitError)


Version-Release number of selected component (if applicable):
cfme-5.5.0.12-rc2.1.el7cf.x86_64


How reproducible:

100%

Steps to Reproduce:
1. install latest cfme 
2. less /var/www/miq/vmdb/log/evm.log
3.

Actual results:

we see git exception in log

Expected results:

we should not have a git error logged in fvm.log

Additional info:

/opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git/git_proxy.rb:155:in `allowed_in_path': The git source git://github.com/ManageIQ/handsoap.git is not yet checked out. Please run `bundle install` before trying to start your application (Bundler::GitError)
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git/git_proxy.rb:47:in `revision'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:215:in `revision'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:85:in `install_path'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/path.rb:110:in `expanded_path'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/path.rb:132:in `load_spec_files'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:188:in `load_spec_files'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/path.rb:92:in `local_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:159:in `specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:550:in `block in converge_locked_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:539:in `each'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:539:in `converge_locked_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:195:in `resolve'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:140:in `specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:185:in `specs_for'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:174:in `requested_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/environment.rb:18:in `requested_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/runtime.rb:13:in `setup'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler.rb:127:in `setup'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/setup.rb:18:in `<top (required)>'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:128:in `require'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:128:in `rescue in require'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:39:in `require'
        from /var/www/miq/vmdb/config/boot.rb:6:in `<top (required)>'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54:in `require'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54:in `require'
        from /var/www/miq/vmdb/script/rails:5:in `<main>'
/opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git/git_proxy.rb:155:in `allowed_in_path': The git source git://github.com/ManageIQ/handsoap.git is not yet checked out. Please run `bundle install` before trying to start your application (Bundler::GitError)
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git/git_proxy.rb:47:in `revision'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:215:in `revision'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:85:in `install_path'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/path.rb:110:in `expanded_path'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/path.rb:132:in `load_spec_files'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:188:in `load_spec_files'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/path.rb:92:in `local_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/source/git.rb:159:in `specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:550:in `block in converge_locked_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:539:in `each'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:539:in `converge_locked_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:195:in `resolve'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:140:in `specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:185:in `specs_for'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/definition.rb:174:in `requested_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/environment.rb:18:in `requested_specs'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/runtime.rb:13:in `setup'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler.rb:127:in `setup'
        from /opt/rh/cfme-gemset/gems/bundler-1.10.6/lib/bundler/setup.rb:18:in `<top (required)>'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:128:in `require'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:128:in `rescue in require'
        from /opt/rh/rh-ruby22/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:39:in `require'
        from /var/www/miq/vmdb/config/boot.rb:6:in `<top (required)>'
Comment 3 Aziza Karol 2016-01-19 04:51:47 EST
The git error is still observed in evm.log

version:5.5.2.1.20160114044944_395c086

evm.log:
Bundler::GitError: The git source git://github.com/ManageIQ/handsoap.git is not yet checked out. Please run `bundle install` before trying to start your application
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/git/git_proxy.rb:183:in `allowed_in_path'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/git/git_proxy.rb:47:in `revision'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/git.rb:215:in `revision'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/git.rb:87:in `install_path'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/path.rb:110:in `expanded_path'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/path.rb:132:in `load_spec_files'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/git.rb:188:in `load_spec_files'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/path.rb:92:in `local_specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/source/git.rb:159:in `specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:541:in `block in converge_locked_specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:530:in `each'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:530:in `converge_locked_specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:192:in `resolve'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:137:in `specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:182:in `specs_for'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/definition.rb:171:in `requested_specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/environment.rb:18:in `requested_specs'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/runtime.rb:13:in `setup'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler.rb:92:in `setup'
/opt/rh/cfme-gemset/gems/bundler-1.11.2/lib/bundler/setup.rb:18:in `<top (required)>'
/var/www/miq/vmdb/config/boot.rb:6:in `<top (required)>'
/var/www/miq/vmdb/config/application.rb:1:in `<top (required)>'
/var/www/miq/vmdb/Rakefile:5:in `<top (required)>'
LoadError: cannot load such file -- bundler/setup
/var/www/miq/vmdb/config/boot.rb:6:in `<top (required)>'
/var/www/miq/vmdb/config/application.rb:1:in `<top (required)>'
/var/www/miq/vmdb/Rakefile:5:in `<top (required)>'
Comment 6 Nick Carboni 2016-08-02 16:00:13 EDT
The cfme_productization MR from comment 5 was incorrect. The correct MR is https://gitlab.cloudforms.lab.eng.rdu2.redhat.com/cloudforms/distgit-cfme-appliance/merge_requests/4

Note You need to log in before you can comment on or make changes to this bug.