Bug 1290537 - Review Request: perl-HTTP-Tinyish - HTTP::Tiny compatible HTTP client wrappers
Review Request: perl-HTTP-Tinyish - HTTP::Tiny compatible HTTP client wrappers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1290542
  Show dependency treegraph
 
Reported: 2015-12-10 13:16 EST by Petr Šabata
Modified: 2016-02-16 10:25 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-HTTP-Tinyish-0.06-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 10:25:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ppisar: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Petr Šabata 2015-12-10 13:16:19 EST
Spec URL: https://psabata.fedorapeople.org/pkgs/perl-HTTP-Tinyish/perl-HTTP-Tinyish.spec
SRPM URL: https://psabata.fedorapeople.org/pkgs/perl-HTTP-Tinyish/perl-HTTP-Tinyish-0.06-1.fc23.src.rpm
Description:
HTTP::Tinyish is a wrapper module for HTTP client modules LWP, HTTP::Tiny
and HTTP client software curl and wget.
Fedora Account System Username: psabata
Comment 1 Upstream Release Monitoring 2015-12-11 04:05:39 EST
ppisar's scratch build of perl-HTTP-Tinyish-0.06-1.fc24.src.rpm for f24 completed http://koji.fedoraproject.org/koji/taskinfo?taskID=12149066
Comment 2 Petr Pisar 2015-12-11 04:28:04 EST
URL and Source0 addresses are usable. Ok.
Source archive is original (SHA-256: 0a5a0cf275e0e030779460c15d369f90aafc8a13094a61b93156d9c1602d3ca3). Ok.
Summary is Ok.
Description is Ok.
License verified from README, LICENSE, lib/HTTP/Tinyish.pm. Ok.
No XS code, noarch BuildArch is Ok.

TODO: Correct the LWP minimal version in the comment to 5.802 (lib/HTTP/Tinyish/LWP.pm:5).

Test::Pod is not used. Ok.
All test pass. Ok.

$ rpmlint perl-HTTP-Tinyish.spec ../SRPMS/perl-HTTP-Tinyish-0.06-1.fc24.src.rpm ../RPMS/noarch/perl-HTTP-Tinyish-* 
perl-HTTP-Tinyish-Curl.noarch: W: no-documentation
perl-HTTP-Tinyish-HTTPTiny.noarch: W: no-documentation
perl-HTTP-Tinyish-LWP.noarch: W: no-documentation
perl-HTTP-Tinyish-Wget.noarch: W: no-documentation
6 packages and 1 specfiles checked; 0 errors, 4 warnings.
rpmlint is Ok.

$ for P in ../RPMS/noarch/perl-HTTP-Tinyish-*;do echo "${P}:"; rpm -q -lv -p "$P"; done
../RPMS/noarch/perl-HTTP-Tinyish-0.06-1.fc24.noarch.rpm:
drwxr-xr-x    2 root    root                        0 Dec 11 10:02 /usr/share/doc/perl-HTTP-Tinyish
-rw-r--r--    1 root    root                      681 Sep 26 19:22 /usr/share/doc/perl-HTTP-Tinyish/Changes
-rw-r--r--    1 root    root                     3403 Sep 26 19:22 /usr/share/doc/perl-HTTP-Tinyish/README
drwxr-xr-x    2 root    root                        0 Dec 11 10:02 /usr/share/licenses/perl-HTTP-Tinyish
-rw-r--r--    1 root    root                    18370 Sep 26 19:22 /usr/share/licenses/perl-HTTP-Tinyish/LICENSE
-rw-r--r--    1 root    root                     2641 Dec 11 10:02 /usr/share/man/man3/HTTP::Tinyish.3pm.gz
-rw-r--r--    1 root    root                     4872 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish.pm
-rw-r--r--    1 root    root                     2181 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish/Base.pm
../RPMS/noarch/perl-HTTP-Tinyish-Curl-0.06-1.fc24.noarch.rpm:
drwxr-xr-x    2 root    root                        0 Dec 11 10:02 /usr/share/licenses/perl-HTTP-Tinyish-Curl
-rw-r--r--    1 root    root                    18370 Sep 26 19:22 /usr/share/licenses/perl-HTTP-Tinyish-Curl/LICENSE
-rw-r--r--    1 root    root                     3330 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish/Curl.pm
../RPMS/noarch/perl-HTTP-Tinyish-HTTPTiny-0.06-1.fc24.noarch.rpm:
drwxr-xr-x    2 root    root                        0 Dec 11 10:02 /usr/share/licenses/perl-HTTP-Tinyish-HTTPTiny
-rw-r--r--    1 root    root                    18370 Sep 26 19:22 /usr/share/licenses/perl-HTTP-Tinyish-HTTPTiny/LICENSE
-rw-r--r--    1 root    root                      595 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish/HTTPTiny.pm
../RPMS/noarch/perl-HTTP-Tinyish-LWP-0.06-1.fc24.noarch.rpm:
drwxr-xr-x    2 root    root                        0 Dec 11 10:02 /usr/share/licenses/perl-HTTP-Tinyish-LWP
-rw-r--r--    1 root    root                    18370 Sep 26 19:22 /usr/share/licenses/perl-HTTP-Tinyish-LWP/LICENSE
-rw-r--r--    1 root    root                     2420 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish/LWP.pm
../RPMS/noarch/perl-HTTP-Tinyish-Wget-0.06-1.fc24.noarch.rpm:
drwxr-xr-x    2 root    root                        0 Dec 11 10:02 /usr/share/licenses/perl-HTTP-Tinyish-Wget
-rw-r--r--    1 root    root                    18370 Sep 26 19:22 /usr/share/licenses/perl-HTTP-Tinyish-Wget/LICENSE
-rw-r--r--    1 root    root                     4677 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish/Wget.pm

FIX: The perl-HTTP-Tinyish package should own /usr/share/perl5/vendor_perl/HTTP directory.

$ for P in ../RPMS/noarch/perl-HTTP-Tinyish-*;do echo "${P}:"; rpm -q --requires -p "$P" | sort -f | uniq -c; done
../RPMS/noarch/perl-HTTP-Tinyish-0.06-1.fc24.noarch.rpm:
      1 perl(:MODULE_COMPAT_5.22.0)
      1 perl(Carp)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-Curl-0.06-1.fc24.noarch.rpm:
      1 curl
      1 perl(File::Temp)
      1 perl(File::Which)
      1 perl(HTTP::Tinyish::Base)
      1 perl(IPC::Run3)
      1 perl(parent)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-HTTPTiny-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tiny) >= 0.054
      1 perl(HTTP::Tinyish::Base)
      1 perl(parent)
      1 perl(strict)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-LWP-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tinyish::Base)
      1 perl(LWP) >= 5.802
      1 perl(LWP::UserAgent)
      1 perl(parent)
      1 perl(strict)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-Wget-0.06-1.fc24.noarch.rpm:
      1 perl(File::Which)
      1 perl(HTTP::Tinyish::Base)
      1 perl(IPC::Run3)
      1 perl(parent)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
      1 wget

FIX: All the backend packages must require perl(:MODULE_COMPAT_*) symbol.

TODO: It's possible to install perl-HTTP-Tinyish without any backend now. I recommend to provide an RPM symbol by all the backends and require the symbol by perl-HTTP-Tinyish.

$ for P in ../RPMS/noarch/perl-HTTP-Tinyish-*;do echo "${P}:"; rpm -q --provides -p "$P" | sort -f | uniq -c; done
../RPMS/noarch/perl-HTTP-Tinyish-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tinyish) = 0.06
      1 perl(HTTP::Tinyish::Base)
      1 perl-HTTP-Tinyish = 0.06-1.fc24
../RPMS/noarch/perl-HTTP-Tinyish-Curl-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tinyish::Curl)
      1 perl-HTTP-Tinyish-Curl = 0.06-1.fc24
../RPMS/noarch/perl-HTTP-Tinyish-HTTPTiny-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tinyish::HTTPTiny)
      1 perl-HTTP-Tinyish-HTTPTiny = 0.06-1.fc24
../RPMS/noarch/perl-HTTP-Tinyish-LWP-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tinyish::LWP)
      1 perl-HTTP-Tinyish-LWP = 0.06-1.fc24
../RPMS/noarch/perl-HTTP-Tinyish-Wget-0.06-1.fc24.noarch.rpm:
      1 perl(HTTP::Tinyish::Wget)
      1 perl-HTTP-Tinyish-Wget = 0.06-1.fc24
Binary provides are Ok.

$ resolvedeps rawhide ../RPMS/noarch/perl-HTTP-Tinyish-*;
Binary dependencies resolvable. Ok.

Package builds in F24 (http://koji.fedoraproject.org/koji/taskinfo?taskID=12149066). Ok.

Otherwise the package is in line with Fedora and Perl packaging guidelines.

Please correct all `FIX' items, consider fixing `TODO' items and provide new spec file.
Resolution: Package NOT approved.
Comment 3 Petr Šabata 2015-12-11 06:52:10 EST
The possibility of no backends was intended as a feature but I see it could
prove problematic in koji.

Spec URL: https://psabata.fedorapeople.org/pkgs/perl-HTTP-Tinyish/perl-HTTP-Tinyish.spec
SRPM URL: https://psabata.fedorapeople.org/pkgs/perl-HTTP-Tinyish/perl-HTTP-Tinyish-0.06-2.fc23.src.rpm
Comment 4 Upstream Release Monitoring 2015-12-11 07:21:55 EST
ppisar's scratch build of perl-HTTP-Tinyish-0.06-2.fc24.src.rpm for f24 completed http://koji.fedoraproject.org/koji/taskinfo?taskID=12152059
Comment 5 Petr Pisar 2015-12-11 07:31:25 EST
Spec file changes:

--- perl-HTTP-Tinyish.spec.old  2015-12-10 19:15:11.000000000 +0100
+++ perl-HTTP-Tinyish.spec      2015-12-11 12:42:07.000000000 +0100
@@ -1,6 +1,6 @@
 Name:           perl-HTTP-Tinyish
 Version:        0.06
-Release:        1%{?dist}
+Release:        2%{?dist}
 Summary:        HTTP::Tiny compatible HTTP client wrappers
 License:        GPL+ or Artistic
 URL:            http://search.cpan.org/dist/HTTP-Tinyish/
@@ -18,7 +18,7 @@
 # BuildRequires:  perl(File::Which)
 # BuildRequires:  perl(HTTP::Tiny) >= 0.054
 # BuildRequires:  perl(IPC::Run3)
-# BuildRequires:  perl(LWP) >= 5.002
+# BuildRequires:  perl(LWP) >= 5.802
 # BuildRequires:  perl(LWP::Protocol::https)
 # BuildRequires:  perl(LWP::UserAgent)
 # BuildRequires:  perl(parent)
@@ -26,6 +26,7 @@
 BuildRequires:  perl(JSON::PP)
 BuildRequires:  perl(Test::More) >= 0.96
 Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
+Requires:       perl(:HTTP-Tinyish:backend)
 Recommends:     perl(HTTP::Tinyish::LWP)

 %global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(HTTP::Tiny\\)$
@@ -34,30 +35,38 @@
 HTTP::Tinyish is a wrapper module for HTTP client modules LWP, HTTP::Tiny
 and HTTP client software curl and wget.

-%package       Curl
-Summary:       HTTP::Tinyish curl backend
-Requires:      curl
+%package        Curl
+Summary:        HTTP::Tinyish curl backend
+Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
+Requires:       curl
+Provides:       perl(:HTTP-Tinyish:backend)

 %description Curl
 %{summary}.

-%package       HTTPTiny
-Summary:       HTTP::Tinyish HTTP::Tiny backend
-Requires:      perl(HTTP::Tiny) >= 0.054
+%package        HTTPTiny
+Summary:        HTTP::Tinyish HTTP::Tiny backend
+Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
+Requires:       perl(HTTP::Tiny) >= 0.054
+Provides:       perl(:HTTP-Tinyish:backend)

 %description HTTPTiny
 %{summary}.

-%package       LWP
-Summary:       HTTP::Tinyish LWP backend
-Recommends:    perl(LWP::Protocol::https)
+%package        LWP
+Summary:        HTTP::Tinyish LWP backend
+Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
+Provides:       perl(:HTTP-Tinyish:backend)
+Recommends:     perl(LWP::Protocol::https)

 %description LWP
 %{summary}.

-%package       Wget
-Summary:       HTTP::Tinyish wget backend
-Requires:      wget
+%package        Wget
+Summary:        HTTP::Tinyish wget backend
+Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
+Requires:       wget
+Provides:       perl(:HTTP-Tinyish:backend)

 %description Wget
 %{summary}.
@@ -81,6 +90,7 @@
 %files
 %license LICENSE
 %doc Changes README
+%dir %{perl_vendorlib}/HTTP
 %{perl_vendorlib}/HTTP/Tinyish.pm
 %{perl_vendorlib}/HTTP/Tinyish/Base.pm
 %{_mandir}/man3/HTTP::Tinyish.*
@@ -102,5 +112,8 @@
 %{perl_vendorlib}/HTTP/Tinyish/Wget.pm

 %changelog
+* Fri Dec 11 2015 Petr Šabata <contyk@redhat.com> - 0.06-2
+- Address the reviewer's concerns
+
 * Thu Dec 10 2015 Petr Šabata <contyk@redhat.com> 0.06-1
 - Initial packaging


> TODO: Correct the LWP minimal version in the comment to 5.802
> (lib/HTTP/Tinyish/LWP.pm:5).
-# BuildRequires:  perl(LWP) >= 5.002
+# BuildRequires:  perl(LWP) >= 5.802
Ok.

$ rpmlint perl-HTTP-Tinyish.spec ../SRPMS/perl-HTTP-Tinyish-0.06-2.fc24.src.rpm ../RPMS/noarch/perl-HTTP-Tinyish-*
perl-HTTP-Tinyish.spec:42: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.spec:51: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.spec:59: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.spec:69: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.src:42: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.src:51: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.src:59: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish.src:69: W: unversioned-explicit-provides perl(:HTTP-Tinyish:backend)
perl-HTTP-Tinyish-Curl.noarch: W: no-documentation
perl-HTTP-Tinyish-HTTPTiny.noarch: W: no-documentation
perl-HTTP-Tinyish-LWP.noarch: W: no-documentation
perl-HTTP-Tinyish-Wget.noarch: W: no-documentation
6 packages and 1 specfiles checked; 0 errors, 12 warnings.
rpmlint is Ok.

$ rpm -q -lv -p ../RPMS/noarch/perl-HTTP-Tinyish-0.06-2.fc24.noarch.rpm 
drwxr-xr-x    2 root    root                        0 Dec 11 13:19 /usr/share/doc/perl-HTTP-Tinyish
-rw-r--r--    1 root    root                      681 Sep 26 19:22 /usr/share/doc/perl-HTTP-Tinyish/Changes
-rw-r--r--    1 root    root                     3403 Sep 26 19:22 /usr/share/doc/perl-HTTP-Tinyish/README
drwxr-xr-x    2 root    root                        0 Dec 11 13:19 /usr/share/licenses/perl-HTTP-Tinyish
-rw-r--r--    1 root    root                    18370 Sep 26 19:22 /usr/share/licenses/perl-HTTP-Tinyish/LICENSE
-rw-r--r--    1 root    root                     2641 Dec 11 13:18 /usr/share/man/man3/HTTP::Tinyish.3pm.gz
drwxr-xr-x    2 root    root                        0 Dec 11 13:19 /usr/share/perl5/vendor_perl/HTTP
-rw-r--r--    1 root    root                     4872 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish.pm
-rw-r--r--    1 root    root                     2181 Sep 26 19:22 /usr/share/perl5/vendor_perl/HTTP/Tinyish/Base.pm

> FIX: The perl-HTTP-Tinyish package should own
> /usr/share/perl5/vendor_perl/HTTP directory.
Ok.

FIX: The perl-HTTP-Tinyish package should also own /usr/share/perl5/vendor_perl/HTTP/Tinyish directory.

> FIX: All the backend packages must require perl(:MODULE_COMPAT_*) symbol.
$ for P in ../RPMS/noarch/perl-HTTP-Tinyish-*;do echo "${P}:"; rpm -q --requires -p "$P" | sort -f | uniq -c; done
../RPMS/noarch/perl-HTTP-Tinyish-0.06-2.fc24.noarch.rpm:
      1 perl(:HTTP-Tinyish:backend)
      1 perl(:MODULE_COMPAT_5.22.0)
      1 perl(Carp)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-Curl-0.06-2.fc24.noarch.rpm:
      1 curl
      1 perl(:MODULE_COMPAT_5.22.0)
      1 perl(File::Temp)
      1 perl(File::Which)
      1 perl(HTTP::Tinyish::Base)
      1 perl(IPC::Run3)
      1 perl(parent)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-HTTPTiny-0.06-2.fc24.noarch.rpm:
      1 perl(:MODULE_COMPAT_5.22.0)
      1 perl(HTTP::Tiny) >= 0.054
      1 perl(HTTP::Tinyish::Base)
      1 perl(parent)
      1 perl(strict)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-LWP-0.06-2.fc24.noarch.rpm:
      1 perl(:MODULE_COMPAT_5.22.0)
      1 perl(HTTP::Tinyish::Base)
      1 perl(LWP) >= 5.802
      1 perl(LWP::UserAgent)
      1 perl(parent)
      1 perl(strict)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
../RPMS/noarch/perl-HTTP-Tinyish-Wget-0.06-2.fc24.noarch.rpm:
      1 perl(:MODULE_COMPAT_5.22.0)
      1 perl(File::Which)
      1 perl(HTTP::Tinyish::Base)
      1 perl(IPC::Run3)
      1 perl(parent)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
      1 wget
Binary requires are Ok.

$ resolvedeps rawhide ../RPMS/noarch/perl-HTTP-Tinyish-*   
Binary dependencies resolvable. Ok.

> TODO: It's possible to install perl-HTTP-Tinyish without any backend now.
> I recommend to provide an RPM symbol by all the backends and require the
> symbol by perl-HTTP-Tinyish.

I'd rather see `perl-HTTP-Tinyish-backend' than `perl(:HTTP-Tinyish:backend)', but that's matter of taste.
Ok.

Package builds in F24 (http://koji.fedoraproject.org/koji/taskinfo?taskID=12152059). Ok.

Please correct the `FIX' issue before building the package.
Resolution: Package APPROVED.
Comment 6 Petr Šabata 2015-12-11 08:41:54 EST
(In reply to Petr Pisar from comment #5)
> FIX: The perl-HTTP-Tinyish package should also own
> /usr/share/perl5/vendor_perl/HTTP/Tinyish directory.

Oh yes...

> > TODO: It's possible to install perl-HTTP-Tinyish without any backend now.
> > I recommend to provide an RPM symbol by all the backends and require the
> > symbol by perl-HTTP-Tinyish.
> 
> I'd rather see `perl-HTTP-Tinyish-backend' than
> `perl(:HTTP-Tinyish:backend)', but that's matter of taste.
> Ok.

It's just an internal symbol, I prefer it this way -- it prevents
a hypothetical future conflict with the currently non-existant
HTTP-Tinyish-backend CPAN distribution.  But you never know.

Thanks for the review.
Comment 7 Gwyn Ciesla 2015-12-11 10:16:41 EST
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/perl-HTTP-Tinyish
Comment 8 Fedora Update System 2015-12-11 15:19:23 EST
perl-HTTP-Tinyish-0.06-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-58cb37300f
Comment 9 Fedora Update System 2015-12-11 22:22:25 EST
perl-HTTP-Tinyish-0.06-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-HTTP-Tinyish'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-58cb37300f
Comment 10 Fedora Update System 2015-12-22 17:05:07 EST
perl-HTTP-Tinyish-0.06-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.