Bug 1290538 - Oslo messaging always connecting to the frist configured rabbitmq broker
Oslo messaging always connecting to the frist configured rabbitmq broker
Status: CLOSED DUPLICATE of bug 1267736
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 7.0 (Kilo)
Assigned To: Peter Lemenkov
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 13:16 EST by Jeremy
Modified: 2016-04-18 02:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 13:30:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-12-10 13:16:51 EST
Description of problem:
What problem/issue/behavior are you having trouble with?  What do you expect to see?

Openstack services always connect to the first message broker defined in the rabbit_hosts list. 
This issue was solved in Icehouse but was introduced again during the refactor done here:
https://github.com/openstack/oslo.messaging/commit/973301aa70527171749fa34897276c43898aeeb2

This issue impacts in the load balancing of rabbitmq connections and introduces a degradation of the service when the first controller is down (as Oslo always try to connect to the Stopped broker, and after the failure, it connects to the second one)

The patch has been submitted upstream:
https://review.openstack.org/#/c/231039/

We would like to backport it downstream as soon as possible

Version-Release number of selected component (if applicable):
rabbitmq-server-3.3.5-4.el7
Comment 1 John Eckersberg 2015-12-10 13:30:17 EST

*** This bug has been marked as a duplicate of bug 1267736 ***

Note You need to log in before you can comment on or make changes to this bug.