Bug 1290552 - livemedia-creator --resultdir is ignored with --make-disk
livemedia-creator --resultdir is ignored with --make-disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks: ovirt-node-ng-platform
  Show dependency treegraph
 
Reported: 2015-12-10 14:03 EST by Ryan Barry
Modified: 2016-11-03 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: lorax-19.6.67-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:45:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Barry 2015-12-10 14:03:23 EST
Description of problem:
livemedia-creator ignores the value of --resultdir

Version-Release number of selected component (if applicable):
lorax-19.6.66-1.2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. livemedia-creator --ks ovirt-node-ng.ks --iso /tmp/boot.iso --resultdir /tmp/foobar --make-disk

Actual results:
The disk image is in /var/tmp

Expected results:
The disk image is in the directory specified by --resultdir

Additional info:
Also doesn't work with --image-only

This problem is not reproducible upstream. It's a very quick/easy fix needed downstream-only.

A quick read of the code shows that this probably works with --make-iso, --make-appliance, and --make-pxe-live, just not --make-disk.
Comment 4 errata-xmlrpc 2016-11-03 19:45:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2165.html

Note You need to log in before you can comment on or make changes to this bug.