Bug 1290554 - When using an SSL enabled Openstack Infra provider the toolbar doesn't switch Hosts to Nodes
When using an SSL enabled Openstack Infra provider the toolbar doesn't switch...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Ola Pavlenko
: ZStream
Depends On: 1288496
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 14:15 EST by John Prause
Modified: 2017-08-29 23:47 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288496
Environment:
Last Closed: 2016-02-10 10:24:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
undercloud SSL shows nodes (61.50 KB, image/png)
2016-02-01 08:15 EST, Ronnie Rasouli
no flags Details

  None (edit)
Comment 1 Harpreet Kataria 2015-12-17 14:03:50 EST
https://github.com/ManageIQ/manageiq/pull/5891
Comment 2 CFME Bot 2015-12-17 19:24:24 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/aadec88f7e406e8b43de9c31d6a72b79b60e4492

commit aadec88f7e406e8b43de9c31d6a72b79b60e4492
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Dec 17 14:02:44 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Dec 17 17:59:23 2015 -0500

    Fixed model name passed in to hybrid_name method.
    
    - Incorrect model name was causing incorrect label to be displayed on the secondary navigation bar. To recreate this issue db should only contain openstack Hosts, and no openstack Clusters.
    - Added spec test to verify labels for Hosts & Clusters in different modes depending upon existence of openstack/non-openstack records in the db
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288496
    https://bugzilla.redhat.com/show_bug.cgi?id=1290554

 app/presenters/menu/default_menu.rb       |  4 +-
 spec/presenters/menu/default_menu_spec.rb | 61 +++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+), 2 deletions(-)
Comment 3 CFME Bot 2015-12-18 15:37:54 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c77451d21dc14dbbf864c0ef99ee017c60f5a11f

commit c77451d21dc14dbbf864c0ef99ee017c60f5a11f
Merge: 72e6f8d 21f80d3
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Dec 18 15:35:32 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Dec 18 15:35:32 2015 -0500

    Merge branch '55z_pr_5891' into '5.5.z'
    
    Fixed model name passed in to hybrid_name method.
    
    - Incorrect model name was causing incorrect label to be displayed on the secondary navigation bar. To recreate this issue db should only contain openstack Hosts, and no openstack Clusters.
    - Added spec test to verify labels for Hosts & Clusters in different modes depending upon existence of openstack/non-openstack records in the db
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288496
    https://bugzilla.redhat.com/show_bug.cgi?id=1290554
    (cherry picked from commit aadec88)
    
    @dclarizi this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5891
    
    See merge request !640

 app/presenters/menu/default_menu.rb       |  4 +-
 spec/presenters/menu/default_menu_spec.rb | 61 +++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+), 2 deletions(-)
Comment 4 CFME Bot 2015-12-18 15:38:03 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=21f80d3b9a98b08129351d596928424171d1c7e8

commit 21f80d3b9a98b08129351d596928424171d1c7e8
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Dec 17 14:02:44 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 18 13:55:22 2015 -0500

    Fixed model name passed in to hybrid_name method.
    
    - Incorrect model name was causing incorrect label to be displayed on the secondary navigation bar. To recreate this issue db should only contain openstack Hosts, and no openstack Clusters.
    - Added spec test to verify labels for Hosts & Clusters in different modes depending upon existence of openstack/non-openstack records in the db
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288496
    https://bugzilla.redhat.com/show_bug.cgi?id=1290554
    (cherry picked from commit aadec88)

 app/presenters/menu/default_menu.rb       |  4 +-
 spec/presenters/menu/default_menu_spec.rb | 61 +++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+), 2 deletions(-)
Comment 6 Ronnie Rasouli 2016-02-01 08:15 EST
Created attachment 1120110 [details]
undercloud SSL shows nodes
Comment 7 Ronnie Rasouli 2016-02-01 08:16:30 EST
Tested with 5.5.2.4.20160127105142_395c086

See attached, the toolbar shows nodes
Comment 8 errata-xmlrpc 2016-02-10 10:24:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.