Bug 1290563 - m2crypto FTBFS on all branches if ccache is enabled
m2crypto FTBFS on all branches if ccache is enabled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: swig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 14:51 EST by Sergio Monteiro Basto
Modified: 2016-01-28 13:23 EST (History)
5 users (show)

See Also:
Fixed In Version: swig-3.0.8-2.fc24 swig-3.0.7-8.fc23 swig-3.0.7-5.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:27:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error: command 'swig' failed with exit status 1 (8.54 KB, text/plain)
2015-12-11 12:36 EST, Sergio Monteiro Basto
no flags Details

  None (edit)
Description Sergio Monteiro Basto 2015-12-10 14:51:15 EST
Description of problem:
Can't build it from sources

Version-Release number of selected component (if applicable):
m2crypto-0.22.5-3.

How reproducible:
fedpkg clone m2crypt
cd m2crypto
fedpkg srpm ; mock -r fedora-rawhide-x86_64 --no-clean --rebuild ./m2crypto-0.22.5-3.fc24.src.rpm

fails 

fedpkg srpm ; mock -r fedora-23-x86_64 --no-clean --rebuild ./m2crypto-0.22.5-2.fc23.src.rpm

fails 

fedpkg srpm ; mock -r fedora-22-x86_64 --no-clean --rebuild ./m2crypto-0.22.5-3.fc24.src.rpm

fails

all in same place :
building 'M2Crypto.__m2crypto' extension
swigging SWIG/_m2crypto.i to SWIG/_m2crypto_wrap.c
swig -python -I/usr/include/python2.7 -I/usr/include -includeall -modern -builtin -outdir build/lib.linux-x86_64-2.7/M2Crypto -D__x86_64__ -o SWIG/_m2crypto_wrap.c SWIG/_m2crypto.i
/usr/include/openssl/opensslconf-x86_64.h:5: Warning 205: CPP #error ""Don't include this file directly, use <openssl/opensslconf.h> instead!"".
SWIG/_ssl.i:820: Error: Syntax error in input(1).
error: command 'swig' failed with exit status 1


Additional info:
I can't find what update makes it fails if is swig or openssl or other .
Comment 1 Sergio Monteiro Basto 2015-12-10 14:57:58 EST
I'm trying understand why we got :

assert m2.ec_key_type_check(ec) ec type error

from https://bugzilla.redhat.com/show_bug.cgi?id=904996#c7  looks like  "We need to get some grip to the handling of missing EC modules" but from https://bugzilla.redhat.com/show_bug.cgi?id=1019390
should be enabled by now !
Comment 2 Miloslav Trmač 2015-12-11 11:18:17 EST
Sorry, can you explain how your comment#1 relates to the FTBFS report? I can’t see any connection.  (And FWIW, the Fedora package did have a working testsuite recently enough, see %check; and reenabling ECC in Fedora only enabled particular algorithms so you may still see failures when using others.)


Also, curiously enough, both a local rebuild (rpmbuild --rebuild) and a Koji build (http://koji.fedoraproject.org/koji/taskinfo?taskID=12155063) work fine for me. I did reproduce a failure in mock but I can’t immediately see a cause.
Comment 3 Sergio Monteiro Basto 2015-12-11 12:36 EST
Created attachment 1104751 [details]
error: command 'swig' failed with exit status 1


in every build I got this error: command 'swig' failed with exit status 1,

I'm trying compare the builds and don't found any difference ...

but problem seems that is only in my machine :(
Comment 4 Miloslav Trmač 2015-12-11 13:45:59 EST
I can see that in mock at least. Still, how does comment #1 relate?
Comment 5 Sergio Monteiro Basto 2015-12-11 16:15:55 EST
I found the problem ! 

which swig
/usr/lib64/ccache/swig

echo $PATH
/usr/lib64/ccache:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin

running command with : 

/usr/bin/swig pass this error 


Now I just don't know if ccache fault , swig  fault or mock fault . 

(In reply to Miloslav Trmač from comment #4)
> Still, how does comment #1 relate?

About comment #1, I'm trying rebuild M2Crypto , because and I want understand why we got assert m2.ec_key_type_check(ec) ec type error [1] , but is a second step not related with FTBFS .  

Thanks.

[1] https://github.com/Tribler/tribler/issues/893
Comment 6 Sergio Monteiro Basto 2015-12-11 18:09:59 EST
/usr/lib64/ccache/swig breaks M2Crypto builds when ccache is enabled 
like bug #1274031 and #1176861 , looks like ccache-swig is evil or is not correct installed .

Thanks
Comment 7 Jitka Plesnikova 2016-01-15 06:39:53 EST
ccache-swig was moved to separate sub-package. 
The way how to use it by default was also changed.

The build passes now when ccache and ccache-swig is installed.
Comment 8 Fedora Update System 2016-01-15 08:17:55 EST
swig-3.0.7-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c3edb3267d
Comment 9 Fedora Update System 2016-01-17 09:24:12 EST
swig-3.0.7-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c3edb3267d
Comment 10 Fedora Update System 2016-01-18 01:48:24 EST
swig-3.0.7-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-03b3eafe60
Comment 11 Fedora Update System 2016-01-19 22:54:19 EST
swig-3.0.7-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-03b3eafe60
Comment 12 Fedora Update System 2016-01-26 13:27:41 EST
swig-3.0.7-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-01-28 13:23:23 EST
swig-3.0.7-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.