Bug 1290564 - Consider disabling ITKv3 compatibility
Consider disabling ITKv3 compatibility
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: InsightToolkit (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mario Ceresa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 14:52 EST by Dmitry Mikhirev
Modified: 2016-01-04 13:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 13:34:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Mikhirev 2015-12-10 14:52:19 EST
Description of problem:

Hello!

I'm currently working on building SimpleITK package for Fedora, that is, in turn, required to build 3D-Slicer. Unfortunately building against InsightToolkit Fedora package is cumbered because it is configured with ITKv3 compatibility enabled. I asked ITK developers for help, and got an answer that building SimleITK against ITK with ITKv3 compatibility is not tested. Some workarounds were also suggested, you can read the whole thread here:

http://public.kitware.com/pipermail/insight-developers/2015-December/024687.html

There are also some more issues introduced by ITKv3 compatibility (that is incomplete anyway), in particular ITK can not handle big images (pixel addresses are 32-bit).

I searched through the Fedora repo and did not find any package depending on InsightToolkit, so disabling ITKv3 compatibility should not break anything. So please consider disabling ITKv3 compatibility in ImageToolkit package or, if it is unacceptable for some reason, removing problematic lines from itkHistogram.h file.
Comment 1 Sebastian Pölsterl 2015-12-23 09:11:33 EST
If you provide a patch, I'd be happy to apply it.
Comment 2 Dmitry Mikhirev 2015-12-23 14:20:48 EST
Patch to disable this feature? It's trivial:

diff --git a/InsightToolkit.spec b/InsightToolkit.spec
index c48c118..f3887b1 100644
--- a/InsightToolkit.spec
+++ b/InsightToolkit.spec
@@ -155,7 +155,7 @@ pushd %{_target_platform}
        -DCMAKE_VERBOSE_MAKEFILE=ON\
        -DBUILD_TESTING=ON\
        -DITK_FORBID_DOWNLOADS=ON \
-       -DITKV3_COMPATIBILITY:BOOL=ON \
+       -DITKV3_COMPATIBILITY:BOOL=OFF \
        -DITK_BUILD_DEFAULT_MODULES:BOOL=ON \
        -DModule_ITKVtkGlue:BOOL=ON \
        -DITK_WRAP_PYTHON:BOOL=OFF \
Comment 3 Sebastian Pölsterl 2016-01-04 13:34:16 EST
Thanks! An updated package is available in rawhide.

Note You need to log in before you can comment on or make changes to this bug.