Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
DescriptionOrion Poplawski
2015-12-10 23:12:13 UTC
Description of problem:
As it currently stands, rpcbind is only activated by connection via /var/run/rpcbind.sock, but not by attempts to connect to the sunrpc UDP or TCP port. So svc_register(..., IPROTO_TCP) fails with:
Cannot register service: RPC: Unable to receive; errno = Connection refused
Version-Release number of selected component (if applicable):
rpcbind-0.2.0-26.el7.x86_64
Now, we probably don't want to have a network facing socket enabled by default, but we could have a separate disabled by default socket:
/usr/lib/systemd/system/rpcbind-network.socket:
[Unit]
Description=RPCbind Server Network Activation Socket
[Socket]
ListenDatagram=111
ListenStream=111
Service=rpcbind.service
[Install]
WantedBy=sockets.target
Interestingly enough, once rpcbind is started by the local /var/run/rpcbind.sock it listens on the UDP and TCP ports anyway. But I suppose that is always necessary?
Except for the fact that just doesn't work. Perhaps what is just needed is to be able to enable and start rpcbind.service directly by having:
[Install]
WantedBy=multi-user.target
in rpcbind.service.
Well, that would be:
[Install]
WantedBy=multi-user.target
Also=rpcbind.socket
to keep the socket activation as well. Workaround is just to do:
ln -s /usr/lib/systemd/system/rpcbind.service /etc/systemd/system/sockets.target.wants/rpcbind.service
manually instead of systemctl enable rpcbind.service.