Bug 129062 - Missing shared libs
Summary: Missing shared libs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-03 16:58 UTC by Ralf Corsepius
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 15:02:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2004-08-03 16:58:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The current ghostscript rpms for FC1 lack the shared libraries
(libgs.so.7).  According to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88175
this bug had been fixed and "CLOSED RAWHIDE" with version 7.07-18.

Unfortunately this bug prevents Fedora Extras to provide gsview rpms
for FC1 (https://bugzilla.fedora.us/show_bug.cgi?id=1940).

I'd therefore ask you to release an update to ghostscript for FC1.


Version-Release number of selected component (if applicable):
ghostscript-7.07-15.2

How reproducible:
Always

Steps to Reproduce:

    

Additional info:

Comment 1 Tim Waugh 2004-08-05 14:27:49 UTC
Please test the update.  Does it work for you?

http://www.redhat.com/archives/fedora-test-list/2004-August/msg00173.html

Comment 2 Ralf Corsepius 2004-08-06 13:56:21 UTC
Thanks a lot for your response! Great!

Some remarks: Some (non-critical) nits in your rpm-spec:

1. You are invoking autoconf, but do not BuildRequires it.
This breaks building the package in mach-chroots. I guess you probably
have autoconf in your default buildsystem configuration, so this
probably doesn't have any impact for you.
[I don't know what is cause for running autoconf at the place it
currently is run (the ijs-patch alone does not require running
autoconf) but I would recommend to use a pregenerated patch instead of
running autoconf.]

2. /usr/lib/libgs.so should probably be moved to ghostscript-devel
(currently in ghostscript).

3. The ghostscript package should probably be added (It now contains
shared libs)
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

4. IMO, ghostscript-devel should 
Require: ghostscript = %{version}-%{release}
unless you're 100% shure, that all ghostscript-devel releases 
are compatible to ghostscript = %{version} packages

BTW: these issues also apply to FC2's ghostscript (7.07-25)

Comment 3 Tim Waugh 2004-08-06 14:04:42 UTC
Thanks for the feedback.

1: this is just what was already shipped -- the only change was to
change a '0' to a '1'.

2: if you do that gs won't run :-)  It dlopen()s it

3: not sure if this is valid -- they are shared libs, but are
dlopened() and so don't need the versioned symlinks

4: again, this is like point 1

The points I most need feedback on are:

a) Does gsview work?
b) Does ghostscript work?

Comment 4 Ralf Corsepius 2004-08-06 15:57:50 UTC
2: sigh, gsview also dlopens "libgs.so" :(

[IMO this is a design flaw; it breaks shared library versioning and
introduces DLL-hell to Linux :(
I already patched one of my rpms to dlopen versioned libraries
cf. https://bugzilla.fedora.us/show_bug.cgi?id=1786]

3: Isn't it required in case packages actually link against the shared
libs? (At the moment there definitely are none).

a) As far gs seems to be concerned, AFAICT: yes.
[Displaying pages seascape/upside-down doesn't seem to work, but I am
not sure if ghostscript is the culprit]  

b) I haven't noticed any apparent breakdown yet.

Comment 5 Tim Waugh 2004-08-06 17:04:49 UTC
I've updated the package for Fedora development in CVS, but I don't
think it's worth re-spinning this update for /sbin/ldconfig and
stricter requires:.

Thanks for the feedback!


Note You need to log in before you can comment on or make changes to this bug.