Bug 129064 - Wireless applet signal strength misleading
Wireless applet signal strength misleading
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
: 129100 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-03 13:14 EDT by Matthew Saltzman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 07:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2004-08-03 13:14:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
While connected to a very weak WAP signal from another building, the
wireless applet nevertheless indicates signal strength near 100%. 
WinXP reports the same signal as "very weak" and wavemon reports s/n
ratios in the single digits.

Disabling the interface leaves the last measured percentage instead of
switching to "N/A".

What is actually being displayed, anyway?  Signal strength as a
percentage of what?

Version-Release number of selected component (if applicable):
gnome-applets-2.6.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. Install and enable wireless applet
2. Connect to a WAP at long distance and watch the signal strength meter.
3. Toggle the wireless interface between up and down.
    

Actual Results:  Signal strength meter indicates "very strong" signal
(90-100%).

When the link is disabled, a percentage still shows in the signal
strength field and "WiFi" still shows in the status box, but is not
updated.

Expected Results:  Signal strength meter should indicate "very weak
signal" (not quite sure what's appropriate).  Disabling the interface
should change the status to indicated that I'm not connected.

Additional info:

On my home netowork, where I'm within about 30 feet of my WAP, signal
strength is in the 70-90% range.
Comment 1 Matthew Saltzman 2004-08-03 21:48:49 EDT
*** Bug 129100 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2004-08-04 07:07:31 EDT
Okay, this is being figured out upstream, but its not trivial. The
link quality reported by the kernel isn't an absolute metric and very
few cards actually report enough information to normalize the value.

Anyway, lets just track the upstream bug:

  http://bugzilla.gnome.org/show_bug.cgi?id=119472

Note You need to log in before you can comment on or make changes to this bug.