Bug 1290719 - Geo-replication doesn't deal properly with sparse files
Geo-replication doesn't deal properly with sparse files
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aravinda VK
: Triaged
Depends On: 1276839
Blocks: glusterfs-3.7.7
  Show dependency treegraph
 
Reported: 2015-12-11 03:45 EST by Aravinda VK
Modified: 2016-04-19 03:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276839
Environment:
Last Closed: 2016-02-15 01:30:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2015-12-11 03:45:25 EST
+++ This bug was initially created as a clone of Bug #1276839 +++

Description of problem:
Without '--sparse' option tar will not properly archive sparse file
and geo-replication will result in non-sparse file on the remote end.


Version-Release number of selected component (if applicable):


How reproducible:
Every time you have sparse files to geo-replicate the remote end will have files full size and not sparse anymore.

Steps to Reproduce:
1. Copy a sparse file into a volume.
2. Wait for geo-replication to copy it to remote cluster.
3. Check the files on the remote end. It's no longer sparse.

Actual results:
Sparse files are no longer sparse after being geo-replicated.

Expected results:
Sparse files must remain sparse after being geo-replicated.

Additional info:
Here is more on how I arrived at this http://markelov.org/wiki/index.php/GlusterFS_3.6.1_on_CentOS_6.5:_geo-replication_and_sparse_files_problem

--- Additional comment from Vijay Bellur on 2015-10-31 06:59:04 EDT ---

REVIEW: http://review.gluster.org/12476 (Add support for sparse files to tarssh method) posted (#1) for review on master by Alex Markelov (alex@markelov.org)

--- Additional comment from Vijay Bellur on 2015-11-01 09:11:42 EST ---

REVIEW: http://review.gluster.org/12476 (Add support for sparse files to tarssh method) posted (#2) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-01 09:50:40 EST ---

REVIEW: http://review.gluster.org/12476 (Add support for sparse files to tarssh method) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)

--- Additional comment from Alex Markelov on 2015-11-21 05:19:47 EST ---

Guys, any progress with this? What about the patch that I submitted?

--- Additional comment from Vijay Bellur on 2015-12-02 01:42:39 EST ---

REVIEW: http://review.gluster.org/12476 (Add support for sparse files to tarssh method) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-02 10:47:33 EST ---

REVIEW: http://review.gluster.org/12476 (Add support for sparse files to tarssh method) posted (#5) for review on master by Vijay Bellur (vbellur@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-10 05:01:12 EST ---

REVIEW: http://review.gluster.org/12476 (Add support for sparse files to tarssh method) posted (#6) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-11 03:27:58 EST ---

COMMIT: http://review.gluster.org/12476 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit eff14863fb6a6da0ccf8a40343160b09f29ea493
Author: Alex Markelov <alex@markelov.org>
Date:   Sat Oct 31 08:30:08 2015 +0000

    Add support for sparse files to tarssh method
    
    Without '--sparse' option tar will not properly archive sparse file
    and geo-replication will result in non-sparse file on the remote end.
    
    Here is more on how I arrived at this
    http://markelov.org/wiki/index.php/GlusterFS_3.6.1_on_CentOS_6.5:_geo-replication_and_sparse_files_problem
    
    Change-Id: I8d671964a1b48bbb916e4a064571221bf3631494
    BUG: 1276839
    Signed-off-by: Alex Markelov <alex@markelov.org>
    Reviewed-on: http://review.gluster.org/12476
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 1 Vijay Bellur 2015-12-11 03:46:48 EST
REVIEW: http://review.gluster.org/12949 (Add support for sparse files to tarssh method) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2015-12-30 23:18:50 EST
COMMIT: http://review.gluster.org/12949 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit d35af52b9e349bff070431af08d3dae4a6fd75a6
Author: Alex Markelov <alex@markelov.org>
Date:   Sat Oct 31 08:30:08 2015 +0000

    Add support for sparse files to tarssh method
    
    Without '--sparse' option tar will not properly archive sparse file
    and geo-replication will result in non-sparse file on the remote end.
    
    Here is more on how I arrived at this
    http://markelov.org/wiki/index.php/GlusterFS_3.6.1_on_CentOS_6.5:_geo-replication_and_sparse_files_problem
    
    Change-Id: I8d671964a1b48bbb916e4a064571221bf3631494
    BUG: 1290719
    Signed-off-by: Alex Markelov <alex@markelov.org>
    Reviewed-on: http://review.gluster.org/12476
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
     (cherry picked from commit eff14863fb6a6da0ccf8a40343160b09f29ea493)
    Reviewed-on: http://review.gluster.org/12949
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.