Bug 1290748 - cluster profile for the newly created on RHSC will not be the same after the creation. [NEEDINFO]
cluster profile for the newly created on RHSC will not be the same after the ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
x86_64 Linux
high Severity high
: ---
: RHGS 3.1.2
Assigned To: Sahina Bose
Triveni Rao
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 05:22 EST by Triveni Rao
Modified: 2016-05-16 00:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: rhsc-3.1.2-0.69
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:12:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sabose: needinfo? (trao)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50717 ovirt-engine-3.5-gluster MERGED webadmin: fixing cluster and tuned profile selection 2015-12-22 01:16 EST
oVirt gerrit 50724 master MERGED webadmin: fixing cluster and tuned profile selection 2015-12-22 01:07 EST
oVirt gerrit 51186 ovirt-engine-3.6 MERGED webadmin: fixing cluster and tuned profile selection 2016-01-14 04:42 EST

  None (edit)
Description Triveni Rao 2015-12-11 05:22:12 EST
Description of problem:
cluster profile for the newly created on RHSC will not be the same after the creation.
if i create a cluster with version 3.5 and selecting random-io as the profile then, after the creation when i check it to edit i see that profile will be pointing to sequential-io profile. But on the backend on the nodes profiles are set properly.


Version-Release number of selected component (if applicable)
rhsc-3.1.2-0.68.el6.noarch

How reproducible:
easily


Steps to Reproduce:
1. create cluster1 with 3.5 version and select random-io profile.
2. after the creation of cluster check the version
3. try to edit the cluster and see that its showing sequetial-io profile instead of random-io.

Actual results:
sequential-io profile is shown instead of randome-io while editing

Expected results:
should show proper profile while editing


Additional info:
Comment 5 Triveni Rao 2015-12-24 02:04:00 EST
this bug is verified with the fixed in version:rhsc-3.1.2-0.69

Steps followed to verify the bug:
1. create cluster1 with 3.5 version and select random-io profile.
2. after the creation of cluster check the version.
3. try to edit the cluster and see that its showing random-io properly.
4. tried with other profile also sequetial-io and found no issues.

[root@dhcp37-40 ~]# rpm -qa | grep rhsc
rhsc-lib-3.1.2-0.69.el6.noarch
rhsc-setup-plugin-ovirt-engine-common-3.1.2-0.69.el6.noarch
rhsc-webadmin-portal-3.1.2-0.69.el6.noarch
rhsc-backend-3.1.2-0.69.el6.noarch
rhsc-setup-plugin-ovirt-engine-3.1.2-0.69.el6.noarch
rhsc-setup-plugins-3.1.2-2.el6rhs.noarch
rhsc-doc-3.1.0-1.el6eng.noarch
rhsc-log-collector-3.1.0-1.0.el6rhs.noarch
rhsc-cli-3.0.0.0-0.2.el6rhs.noarch
rhsc-setup-base-3.1.2-0.69.el6.noarch
rhsc-tools-3.1.2-0.69.el6.noarch
rhsc-dbscripts-3.1.2-0.69.el6.noarch
redhat-access-plugin-rhsc-3.0.0-3.el6rhs.noarch
rhsc-3.1.2-0.69.el6.noarch
rhsc-branding-rhs-3.1.0-1.el6rhs.noarch
rhsc-extensions-api-impl-3.1.2-0.69.el6.noarch
rhsc-monitoring-uiplugin-0.2.4-1.el6rhs.noarch
rhsc-sdk-python-3.0.0.0-0.2.el6rhs.noarch
rhsc-restapi-3.1.2-0.69.el6.noarch
rhsc-setup-3.1.2-0.69.el6.noarch
[root@dhcp37-40 ~]#
Comment 6 Sahina Bose 2015-12-24 02:10:02 EST
Can you also confirm that cluster and tuned selection are persisted for older cluster versions?
Comment 8 errata-xmlrpc 2016-03-01 01:12:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.