Bug 1290777 - No way of enabling Indirect GLX with GDM
No way of enabling Indirect GLX with GDM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
7.2
x86_64 Linux
high Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: ZStream
Depends On:
Blocks: 1274917 1372180
  Show dependency treegraph
 
Reported: 2015-12-11 07:23 EST by John Hodrien
Modified: 2016-11-03 22:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.17.2-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1372180 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:50:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2293 normal SHIPPED_LIVE X.Org X11 server and drivers bug fix and enhancement update 2016-11-03 09:38:01 EDT

  None (edit)
Description John Hodrien 2015-12-11 07:23:32 EST
Description of problem:
Remote OpenGL not working with indirect GLX, and no obvious way of telling GDM to enable it.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.17.2-10.el7.x86_64

How reproducible:
Always using the nvidia proprietary drivers, or most probably any other hardware accelerated drivers that don't use Mesa.

Steps to Reproduce:
1.  Setup machine with nvidia drivers
2.  ssh -Y remotehost
3.  glxinfo

Actual results:
$ glxinfo
name of display: remotehost:33.0
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  27
  Current serial number in output stream:  30


Expected results:
Normal glxinfo output.

Additional info:
Passing an argument +iglx to Xorg enables indirect GLX, and remote OpenGL then works correctly.

Tested with the nouveau driver this works, but that doesn't allow for running CUDA applications.  I assume the Mesa driver underpinning nouveau is doing internal trickery to present as direct GLX even on remote connections that the nVidia driver doesn't, or isn't able, to do.

Related bug is that GDM doesn't allow arbitrary Xorg args to be passed: https://bugzilla.gnome.org/show_bug.cgi?id=586777
Comment 9 errata-xmlrpc 2016-11-03 22:50:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2293.html

Note You need to log in before you can comment on or make changes to this bug.