Bug 1290803 - grub2: grub2-setpassword warn if grub.cfg does not read user.cfg [NEEDINFO]
grub2: grub2-setpassword warn if grub.cfg does not read user.cfg
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2 (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: rmarshall
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 08:47 EST by Tomas Hoger
Modified: 2016-11-04 00:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: grub2-2.02-0.34
Doc Type: Bug Fix
Doc Text:
Cause: A change to add a tool to set the grub password was not recognized if the user had not created a clean configuration. Consequence: Setting the password would never appear to work because the grub configuration was not reading it. Fix: If the user sets the password and their current configuration does not support the new feature, warn them. Result: User will know if they have an extra step to support setting the GRUB password.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:00:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
apetrova: needinfo? (rmarshall)


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2015-12-11 08:47:08 EST
Description of problem:

grub2-setpassword and 01_users reading user.cfg was added in Red Hat Enterprise Linux 7.2.  The relevant code from 01_users is only propagated to grub.cfg when grub2-mkconfig is run.  However, that does not happen during grub2 or kernel packages upgrades, mkconfig is only expected to run during system installation.

If user installed RHEL 7.0 or 7.1 and upgraded to 7.2, their grub.cfg will not attempt to use password set in user.cfg.  I think we need to make grub2-setpassword attempt to detect that user.cfg will be ignored and suggest regeneration of grub.cfg using mkconfig (or is there a better action to do?).  This may be as simple as:

grep -q 'user.cfg' /etc/grub2.cfg || echo 'use grub2-mkconfig to password protection to work'

Version-Release number of selected component (if applicable):

grub2-2.02-0.29.el7.x86_64
Comment 7 errata-xmlrpc 2016-11-04 00:00:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2336.html

Note You need to log in before you can comment on or make changes to this bug.