Bug 1290843 - Error watching build, 'int' object is not iterable
Error watching build, 'int' object is not iterable
Status: CLOSED DUPLICATE of bug 1186994
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 10:42 EST by Ville Skyttä
Modified: 2016-01-12 04:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 04:32:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2015-12-11 10:42:01 EST
Submitted an EPEL7 scratch build from F23 to try something out:

$ koji build --scratch epel7-candidate --arch-override=ppc64le uwsgi-2.0.11.2-7.el7.src.rpm
Uploading srpm: uwsgi-2.0.11.2-7.el7.src.rpm
[====================================] 100% 00:00:02   1.17 MiB 585.44 KiB/sec
Created task: 12154824
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=12154824
Watching tasks (this may be safely interrupted)...
12154824 build (epel7-candidate, uwsgi-2.0.11.2-7.el7.src.rpm): free
TypeError: 'int' object is not iterable
Comment 1 Richard W.M. Jones 2016-01-06 05:57:07 EST
I observed this too with a scratch build against Rawhide:

$ fedpkg srpm
[...]
$ koji build --scratch rawhide /home/rjones/d/fedora/libguestfs/master/libguestfs-1.31.30-1.fc24.src.rpm 
Uploading srpm: /home/rjones/d/fedora/libguestfs/master/libguestfs-1.31.30-1.fc24.src.rpm
[====================================] 100% 00:00:42  19.49 MiB 465.40 KiB/sec
Created task: 12434302
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=12434302
Watching tasks (this may be safely interrupted)...
12434302 build (rawhide, libguestfs-1.31.30-1.fc24.src.rpm): open (buildppcle-03.phx2.fedoraproject.org)
TypeError: 'int' object is not iterable

Strangely enough, using 'koji watch-task 12434302' works fine, so
it's not the actual watch-task step which fails.

koji-1.10.1-1.fc24.noarch
Comment 2 Richard W.M. Jones 2016-01-12 04:32:56 EST

*** This bug has been marked as a duplicate of bug 1186994 ***

Note You need to log in before you can comment on or make changes to this bug.