This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1290860 - Rework list of patches, replace by upstream backports
Rework list of patches, replace by upstream backports
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute (Show other bugs)
7.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
:
: 1284667 (view as bug list)
Depends On:
Blocks: 1301628 1313485
  Show dependency treegraph
 
Reported: 2015-12-11 12:03 EST by Phil Sutter
Modified: 2016-11-03 19:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: iproute-3.10.0-55.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:37:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Sutter 2015-12-11 12:03:42 EST
In RHEL7.2, iproute SRPM currently ships 46 different patches which are applied on top of the vanilla version 3.10.0. Most of them are not formal backports, therefore it is difficult to find out what changes they actually contain.

Also, when dealing with a bug, it's sometimes difficult to find out whether a given candidate for a fix has already been backported (and if that has been done correctly).

Therefore replace all those (partly consolidated) patches by formal backports, oriented at how the same is achieved for the kernel package.

This task has two implications:

1) Since some of the patches from upstream contain more changes than were originally backported into RHEL, it is not possible to do this rework in a clean way (i.e., resulting in identical source code afterwards). This means thorough regression testing has to be performed afterwards as importing bugs by accident can't be excluded categorically.

2) The number of separate patches will drastically increase (a little more than 180 upstream commits have been identified). This makes it even less practical to export them all into the SRPM, therefore follow the example of kernel package here as well, namely uploading tarballs containing already patched sources and referencing them from within the spec file.
Comment 1 Phil Sutter 2015-12-11 12:24:18 EST
Setting this to high priority since it has to be completed first before any other RHEL7.3 related backports to avoid chaos.
Comment 3 Phil Sutter 2016-02-18 07:31:38 EST
*** Bug 1241484 has been marked as a duplicate of this bug. ***
Comment 4 Phil Sutter 2016-02-18 09:33:20 EST
*** Bug 1284667 has been marked as a duplicate of this bug. ***
Comment 5 Phil Sutter 2016-02-18 09:57:56 EST
*** Bug 1297000 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2016-11-03 19:37:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2162.html

Note You need to log in before you can comment on or make changes to this bug.