Bug 1290867 - Installing 350+ errata to a content host timed out in satellite
Installing 350+ errata to a content host timed out in satellite
Status: CLOSED DUPLICATE of bug 1288152
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.2
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
: 1448549 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 12:43 EST by sthirugn@redhat.com
Modified: 2017-05-05 14:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-24 10:39:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Satellite timeout (60.32 KB, image/png)
2015-12-11 12:43 EST, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2015-12-11 12:43:23 EST
Created attachment 1104752 [details]
Satellite timeout

Description of problem:
Installing 350+ errata to a content host timed out

Version-Release number of selected component (if applicable):
Sat 6.1.5 Compose 4

How reproducible:
Always

Steps to Reproduce:
1. Install Sat 6.1.5 Compose x
2. Sync rhel7Server content, promote, publish
3. Create activation key for the above content and associate to corresponding content view
4. Register/subscribe a rhel7 client
5. Go to Satellite UI -> Content -> Errata -> Select 350+ errata and apply to the content host

Note: 
1. Watch /var/log/messages in content host and satellite
2. Watch tail -f /var/log/{pulp,candlepin,foreman*,rhsm,puppet,tomcat*}/{*.log,*.out} in satellite 


Actual results:
Satellite timed out

Expected results:
Satellite finished the errata installation in content host

Additional info:
It looks like pulp traverses through each errata, and bundles some information.  I can see those logs in /var/log/messages in satellite.  This pulp processing is happening for more than an hour now and this made Satellite timeout.  When I write this bug, pulp is still processing errata in the background but content host did not receive any info so far.

Although I observed this in rhel 7 content host, I believe the behavior is same for all rhel5 and rhel6 as well.
Comment 2 sthirugn@redhat.com 2015-12-11 13:43:07 EST
Update:
Although the satellite task timed out, pulp ran in the background and the installation completed in the content host. 

# yum history
Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
ID     | Login user               | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
     7 | System <unset>           | 2015-12-11 13:19 | I, O, U        |  354 EE
     6 | root <root>              | 2015-12-11 11:21 | Install        |   11 E<
     5 | System <unset>           | 2015-12-10 18:15 | Install        |    1 > 
     4 | System <unset>           | 2015-12-10 18:15 | Install        |    1   
     3 | System <unset>           | 2015-12-10 18:12 | Install        |    4   
     2 | System <unset>           | 2015-12-10 18:12 | Install        |   11 EE
     1 | System <unset>           | 2015-12-10 18:02 | Install        |  612   
history list


Note:
Overall it took 2 hours 10 minutes for the entire operation (359 errata installation) to succeed from the moment I triggered the install on satellite till the installation completion in the content host.
Comment 3 Bryan Kearney 2016-07-26 15:08:31 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 8 Waldirio M Pinheiro 2017-05-05 14:20:13 EDT
*** Bug 1448549 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.