Bug 1290868 - 'Software Update' missing in Gnome after update to 7,2 [NEEDINFO]
'Software Update' missing in Gnome after update to 7,2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-packagekit (Show other bugs)
7.2
All All
high Severity high
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
Lucie Maňásková
: Desktop, Regression
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-12-11 12:52 EST by Joe Wright
Modified: 2016-11-04 02:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-packagekit-3.14.3-6.el7
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:20:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lmanasko: needinfo? (rhughes)


Attachments (Terms of Use)

  None (edit)
Description Joe Wright 2015-12-11 12:52:15 EST
Description of problem:
- GUI software updater missing after update to 7.2

Version-Release number of selected component (if applicable):
- RHEL 7.2 GA

How reproducible:
- intermittent

Steps to Reproduce:
1. Update to RHEL 7.2 from a prior version
2.
3.

Actual results:
- package gpk-update-viewer missing
- 'Software Update' enu option missing

Expected results:
- 'Software Update' menu option available

Additional info:

- This issue is resolvable by simply installing gpk-update-viewer, however this is confusing customers as the software update menu option is missing in gnome. What's happening to cause this?
Comment 4 Richard Hughes 2016-02-23 09:49:18 EST
It looks like gnome-software isn't being installed as it's a new package which is probably what we want, as we didn't want to go down the obsoletes route.

The old gnome-packagekit base package is now a common package shared between all others, which is probably what's being updated rather than the others being *installed* at the same time.

What I hink we can do is:
 * create a gnome-packagekit-common that they all depend on
 * make the metata-base package depend on all the subpackages except -common

This should fix upgrades I think.
Comment 5 Matthias Clasen 2016-05-16 13:52:23 EDT
Richard, any update on getting your suggested fix in place ?
Comment 6 Richard Hughes 2016-05-18 10:26:35 EDT
* Wed May 18 2016 Richard Hughes <rhughes@redhat.com> - 3.14.3-6
- Create a -common subpackage and make the "parent" package depend on all
  the split out applications. This fixes upgrades from old versions.
- Resolves: #1290868
Comment 10 Matěj Cepl 2016-08-06 06:18:45 EDT
Software Update is not missing anymore.
Comment 13 errata-xmlrpc 2016-11-04 02:20:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2425.html

Note You need to log in before you can comment on or make changes to this bug.