Bug 1290871 - heat-manage purge_deleted doesn't
heat-manage purge_deleted doesn't
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
All All
unspecified Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Ryan Brown
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 13:04 EST by Dan Yocum
Modified: 2016-04-26 16:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 12:35:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2015-12-11 13:04:24 EST
Description of problem:

$subject

Here's what I'm runninng:

heat-manage purge_deleted -g seconds 60

The heat.raw_template table doesn't change - it remains the same size with the same number of entries.

minutes, hours and days.

There is no deleted_at field in this table - how is the state of 'deleted' determined?

Version-Release number of selected component (if applicable):


openstack-heat-common-2015.1.1-7.el7ost.noarch

How reproducible:

Every


Steps to Reproduce:
1. deploy overcloud
2. delete overcloud
3. run 'heat manage purge_deleted -g minutes 1'

Actual results:

Nothing is deleted, table stays the same size

Expected results:

heat.raw_template gets purged of deleted templates



Additional info:
Comment 2 Zane Bitter 2015-12-11 14:23:20 EST
purge_deleted works on the stack table, that's the one that has deleted_at. Purging that table should clear all of the associated raw_template entries (as well as resources, events, and so on). If there are raw_template entries being left behind, it could be either because the deleted stacks are not being purged or because raw_template entries are leaking (i.e. there are raw_templates not referenced by stacks).

It's quite possibly the former, though, because this bug:

https://bugs.launchpad.net/heat/+bug/1439518

was backported upstream between 2015.1.1 and 2015.1.2. Can you try again with the latest version of Heat? There is a good chance this is already fixed.
Comment 3 Dan Yocum 2015-12-21 09:27:27 EST
Zane - I'm sticking with GA, not installing from a puddle - when will 2015.1.2 be available?
Comment 4 Dan Yocum 2015-12-22 12:35:04 EST
10/10 can confirm, now.  2015.1.2 fixes this problem.  Closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.