Bug 1290885 - subscription-manager-gui --help warnings and traceback
subscription-manager-gui --help warnings and traceback
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Alex Wood
Shwetha Kallesh
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 14:02 EST by John Sefler
Modified: 2016-05-10 16:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:38:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2015-12-11 14:02:45 EST
Description of problem:
A traceback similar to Bug 881095 has surfaced in subscription-manager-gui-1.16 when trying to run 'subscription-manager-gui --help' with no DISPLAY


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-gui pygtk2 gtk2subscription-manager-gui-1.16.6-1.el6.x86_64
pygtk2-2.16.0-3.el6.x86_64
gtk2-2.24.23-6.el6.x86_64


How reproducible:

Steps to Reproduce:
ssh into a rhel68 system without -X X11 forwarding nor -Y trusted X11 forwarding

[jsefler@jseflerT540p ~]$ ssh -x root@jsefler-6.usersys.redhat.com 
Last login: Fri Dec 11 13:53:51 2015 from vpn-53-105.rdu2.redhat.com
[root@jsefler-6 ~]# subscription-manager-gui --help
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager-gui", line 111, in <module>
    from subscription_manager.ga import Gtk as ga_Gtk
  File "/usr/share/rhsm/subscription_manager/ga_loader.py", line 116, in load_module
    return self._import_real_module(fullname, real_module_name, real_module_from)
  File "/usr/share/rhsm/subscription_manager/ga_loader.py", line 119, in _import_real_module
    ret = __import__(module_name, globals(), locals(), [module_from])
  File "/usr/share/rhsm/subscription_manager/ga_impls/ga_gtk2/Gtk.py", line 7, in <module>
    from gtk import AboutDialog, Adjustment, Builder, Button, Calendar, CellRendererPixbuf
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
    _init()
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
    _gtk.init_check()
RuntimeError: could not open display


Actual results:
  above

Expected results:
  Unable to open a display

Additional info:
Comment 6 Shwetha Kallesh 2016-02-25 04:05:18 EST
marking verified!!

[root@dhcp35-72 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.15-1
subscription management rules: 5.15.1
subscription-manager: 1.16.8-3.el6
python-rhsm: 1.16.6-1.el6


[root@dhcp35-72 ~]# subscription-manager-gui --help
Unable to start.  Error: could not open display
Comment 8 errata-xmlrpc 2016-05-10 16:38:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.