Bug 1290908 - RFE: Support Azure VM retirement
RFE: Support Azure VM retirement
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Bill Wei
Jeff Teehan
provider:azure:retire
: FutureFeature
Depends On:
Blocks: 1291274
  Show dependency treegraph
 
Reported: 2015-12-11 16:18 EST by Bill Wei
Modified: 2016-06-29 11:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1291274 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:19:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Bill Wei 2015-12-11 16:18:58 EST
Description of problem:

An Azure instance should be retirable from the Lifecycle menu. 

For selected Azure instances to be qualified for retirement, currently they need to have tag "retire_full" in category "lifecycle". The category can be added through the configuration if not exist.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 CFME Bot 2015-12-23 10:01:02 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d2a164f2370b2cba7de69ffd3a904faeb722a31b

commit d2a164f2370b2cba7de69ffd3a904faeb722a31b
Author:     Bill Wei <bilwei@redhat.com>
AuthorDate: Tue Dec 15 17:11:09 2015 -0500
Commit:     Bill Wei <bilwei@redhat.com>
CommitDate: Tue Dec 15 18:15:16 2015 -0500

    Support Azure VM retirement
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290908

 .../StateMachines/Methods.class/__class__.yaml     | 44 +++++++++++++++++++++-
 .../__methods__/amazon_pre_retirement.rb           |  4 +-
 .../__methods__/azure_pre_retirement.rb            | 10 +++++
 .../__methods__/azure_pre_retirement.yaml          | 12 ++++++
 .../__methods__/openstack_pre_retirement.rb        |  2 +-
 .../Methods.class/checkpreretirement.yaml          |  2 +
 .../StateMachines/Methods.class/preretirement.yaml |  2 +
 .../method_validation/azure_pre_retirement_spec.rb | 24 ++++++++++++
 8 files changed, 95 insertions(+), 5 deletions(-)
 create mode 100644 db/fixtures/ae_datastore/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods.class/__methods__/azure_pre_retirement.rb
 create mode 100644 db/fixtures/ae_datastore/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods.class/__methods__/azure_pre_retirement.yaml
 create mode 100644 spec/automation/unit/method_validation/azure_pre_retirement_spec.rb
Comment 4 CFME Bot 2015-12-23 15:48:42 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8d59b06e6ca33ad59c84ca9434470bf06da71eca

commit 8d59b06e6ca33ad59c84ca9434470bf06da71eca
Author:     Bill Wei <bilwei@redhat.com>
AuthorDate: Tue Dec 15 17:11:09 2015 -0500
Commit:     Bill Wei <bilwei@redhat.com>
CommitDate: Wed Dec 23 13:26:00 2015 -0500

    Support Azure VM retirement
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290908

 .../StateMachines/Methods.class/__class__.yaml     | 44 +++++++++++++++++++++-
 .../__methods__/amazon_pre_retirement.rb           |  4 +-
 .../__methods__/azure_pre_retirement.rb            | 10 +++++
 .../__methods__/azure_pre_retirement.yaml          | 12 ++++++
 .../__methods__/openstack_pre_retirement.rb        |  2 +-
 .../Methods.class/checkpreretirement.yaml          |  2 +
 .../StateMachines/Methods.class/preretirement.yaml |  2 +
 .../method_validation/azure_pre_retirement_spec.rb | 24 ++++++++++++
 8 files changed, 95 insertions(+), 5 deletions(-)
 create mode 100644 db/fixtures/ae_datastore/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods.class/__methods__/azure_pre_retirement.rb
 create mode 100644 db/fixtures/ae_datastore/ManageIQ/Cloud/VM/Retirement/StateMachines/Methods.class/__methods__/azure_pre_retirement.yaml
 create mode 100644 spec/automation/unit/method_validation/azure_pre_retirement_spec.rb
Comment 5 Jeff Teehan 2016-04-18 12:53:47 EDT
This is working correctly from all places where terminate can be initiated.  Moving to verifed as tested on 5.6.0.1 Beta 2 using https://10.16.7.174/miq_request/show/415r4
Comment 7 errata-xmlrpc 2016-06-29 11:19:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.