Bug 1290921 - dnf autoremove remove active kernel
dnf autoremove remove active kernel
Status: CLOSED DUPLICATE of bug 1259865
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All All
unspecified Severity urgent
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 17:14 EST by M_M
Modified: 2016-07-21 10:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 10:24:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debugdata-autoremove (6.37 MB, application/x-xz)
2015-12-14 19:13 EST, M_M
no flags Details
20151221.tar (7.66 MB, application/x-xz)
2015-12-21 12:47 EST, M_M
no flags Details

  None (edit)
Description M_M 2015-12-11 17:14:37 EST
Description of problem:

"dnf autoremove" tries to remove active kernel and some other significant elements falsely.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.dnf autoremove
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Honza Silhan 2015-12-14 07:18:54 EST
can you reproduce it again, attach debugdata [1], post output of `dnf repoquery --installed kernel` and `uname -r`, please?


[1] https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-resolution-problem
Comment 2 M_M 2015-12-14 19:11:23 EST
dnf repoquery --installed kernel
kernel-0:4.2.6-301.fc23.x86_64


uname -a
Linux localhost.localdomain 4.2.6-301.fc23.x86_64 #1 SMP Fri Nov 20 22:22:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

rpm -q libsolv hawkey dnf
libsolv-0.6.14-7.fc23.x86_64
hawkey-0.6.2-3.fc23.x86_64
dnf-1.1.4-2.fc23.noarch


This is freshly installed system, will see whether it will fail with kernel package (probably after installing kernel update may it happen). 

Whatever, represented packages are needed.
Comment 3 M_M 2015-12-14 19:13 EST
Created attachment 1105767 [details]
debugdata-autoremove
Comment 4 M_M 2015-12-21 12:45:24 EST
(In reply to Jan Silhan from comment #1)
> can you reproduce it again, attach debugdata [1], post output of `dnf
> repoquery --installed kernel` and `uname -r`, please?
> 
> 
> [1]
> https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-
> resolution-problem

Another case:


Last metadata expiration check performed 0:08:27 ago on Mon Dec 21 20:33:12 2015.
Dependencies resolved.
================================================================================
 Package                          Arch   Version            Repository     Size
================================================================================
Removing:
 adobe-release-i386               noarch 1.0-1              @@commandline 1.9 k
 fonts-tweak-tool                 x86_64 0.3.2-8.fc23       @fedora       228 k
 gnome-shell-extension-user-theme noarch 3.18.2-1.fc23      @updates      7.0 k
 gnome-tweak-tool                 noarch 3.18.1-1.fc23      @updates      992 k
 gparted                          x86_64 0.23.0-3.fc23      @fedora       6.9 M
 libeasyfc                        x86_64 0.13.0-6.fc23      @fedora        67 k
 libeasyfc-gobject                x86_64 0.13.0-6.fc23      @fedora        15 k
 mc                               x86_64 1:4.8.14-2.fc23    @fedora       6.4 M
 polkit-gnome                     x86_64 0.105-9.fc23       @fedora       365 k
 pycairo                          x86_64 1.10.0-2.fc23      @fedora       1.0 M
 python-bugzilla                  noarch 1.2.2-1.fc23       @fedora       298 k
 python-chardet                   noarch 2.2.1-3.fc23       @fedora       1.1 M
 python-gobject                   x86_64 3.18.2-1.fc23      @updates       15 k
 python-gobject-base              x86_64 3.18.2-1.fc23      @updates      1.1 M
 python-magic                     noarch 5.22-5.fc23        @fedora        17 k
 python-requests                  noarch 2.8.1-1.fc23       @updates      352 k
 python-six                       noarch 1.9.0-3.fc23       @fedora        97 k
 python-talloc                    x86_64 2.1.5-2.fc23       @updates       22 k
 python-urllib3                   noarch 1.12-1.fc23        @updates      403 k
 python-xpyb                      x86_64 1.3.1-5.fc23       @fedora       1.2 M
 rpmfusion-free-release           noarch 23-0.1             @@commandline 9.7 k
 rpmfusion-nonfree-release        noarch 23-0.1             @@commandline 9.9 k
 samba-common-tools               x86_64 2:4.3.3-0.fc23     @updates      1.1 M
 samba-libs                       x86_64 2:4.3.3-0.fc23     @updates      718 k

Transaction Summary
================================================================================
Remove  24 Packages
Comment 5 M_M 2015-12-21 12:47 EST
Created attachment 1108346 [details]
20151221.tar
Comment 6 Michal Luscon 2015-12-23 08:19:59 EST
Was the kernel installed by packagekit? This is potential duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1259865 .
Comment 7 M_M 2015-12-23 09:02:24 EST
(In reply to Michal Luscon from comment #6)
> Was the kernel installed by packagekit? This is potential duplicate of
> https://bugzilla.redhat.com/show_bug.cgi?id=1259865 .

You mean dnf ? Yes.
Comment 8 M_M 2015-12-23 09:23:16 EST
The other side of problem:

 dnf list kernel
Last metadata expiration check performed 2 days, 19:31:02 ago on Sun Dec 20 21:49:49 2015.
Installed Packages
kernel.x86_64                      4.2.6-301.fc23                       @updates
kernel.x86_64                      4.2.7-300.fc23                       @updates
kernel.x86_64                      4.2.8-300.fc23                       @updates

and autoremove doesn't suggest to remove old ones.
Comment 9 Honza Silhan 2016-01-04 08:48:37 EST
We'll take a deep look.
Comment 10 Chris 2016-01-29 19:44:31 EST
I am seeing this bug in F23. The results from using this command are not what I would expect, and from the output I cannot tell if there are legitimate packages that could be 'autoremoved' because the attempt to remove the kernel is stopping the show. This installation was installed one day before I noticed this problem (i.e. fresh install yesterday), and everything has been updated (including a dnf update right before I noticed this issue)



$ sudo dnf autoremove
Last metadata expiration check performed 0:04:10 ago on Fri Jan 29 19:26:48 2016.
Dependencies resolved.
Error: The operation would result in removing the booted kernel: kernel-core-4.3.3-303.fc23.x86_64.
$ 
$ sudo dnf repoquery --installed kernel
kernel-0:4.2.3-300.fc23.x86_64
kernel-0:4.3.3-303.fc23.x86_64
$ uname -r
4.3.3-303.fc23.x86_64
$
Comment 11 Fedora Admin XMLRPC Client 2016-07-08 05:36:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Igor Gnatenko 2016-07-21 10:24:24 EDT

*** This bug has been marked as a duplicate of bug 1259865 ***

Note You need to log in before you can comment on or make changes to this bug.