Bug 129094 - bash built without AFS support
Summary: bash built without AFS support
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bash   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-03 22:48 UTC by Greg Hudson
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: 3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 15:14:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Greg Hudson 2004-08-03 22:48:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
Bug #86514 was fixed by changing the bash build not to use the
--with-afs flag.  Although that change does fix #86514 by disabling
some (apparently bogus) code in redir.c, it also causes bash to use
the mode bits, rather than access(), to determine whether it has
permission to access a file.  Since AFS uses directory ACLs rather
than file mode bits to control access for the most part, looking at
the mode bits frequently yields the wrong result.

Please revert this change and replace it with a more tailored fix,
perhaps by patching redir.c not to contain the offending code.


Version-Release number of selected component (if applicable):
bash-2.05b-29

How reproducible:
Always

Additional info:

Comment 1 Tim Waugh 2004-08-04 08:50:59 UTC
Fixed in CVS.

Comment 2 Tim Waugh 2004-08-04 15:14:58 UTC
Fixed in Fedora development.  This will appear in a future Red Hat
Enterprise Linux release.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.