Bug 1290943 - runc-v0.0.9 is available
runc-v0.0.9 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: runc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Chaloupka
Fedora Extras Quality Assurance
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 19:17 EST by Upstream Release Monitoring
Modified: 2016-04-20 15:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: runc-0.0.9-0.1.git94dc520.fc25 runc-0.0.9-0.2.git94dc520.fc24 runc-0.0.9-0.3.git94dc520.fc23
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 15:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
opencontainer-specs for 0.3.0 specfile patch (1.24 KB, patch)
2016-02-21 07:46 EST, David Voit
no flags Details | Diff
runc version 0.0.8 specfile patch (3.82 KB, patch)
2016-02-21 07:46 EST, David Voit
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-12-11 19:17:41 EST
Latest upstream release: v0.0.6
Current version/release in rawhide: 0.0.5-0.2.git97bc9a7.fc24
URL: https://github.com/opencontainers/runc

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-12-11 19:17:47 EST
Failed to kick off scratch build.

spectool was unable to grab new sources

old source: runc-97bc9a7.tar.gz
old sha256: adbf92066ef88abba7537c6d96171e148cedf5a0c21cbc98b36bd4dc6f85008d

new source: ./runc-97bc9a7.tar.gz
new sha256: adbf92066ef88abba7537c6d96171e148cedf5a0c21cbc98b36bd4dc6f85008d
Comment 2 Upstream Release Monitoring 2016-01-25 19:29:10 EST
Latest upstream release: v0.0.7
Current version/release in rawhide: 0.0.5-0.2.git97bc9a7.fc24
URL: https://github.com/opencontainers/runc

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 3 Upstream Release Monitoring 2016-01-25 19:29:15 EST
Failed to kick off scratch build.

spectool was unable to grab new sources

old source: runc-97bc9a7.tar.gz
old sha256: adbf92066ef88abba7537c6d96171e148cedf5a0c21cbc98b36bd4dc6f85008d

new source: ./runc-97bc9a7.tar.gz
new sha256: adbf92066ef88abba7537c6d96171e148cedf5a0c21cbc98b36bd4dc6f85008d
Comment 4 Upstream Release Monitoring 2016-02-10 19:18:17 EST
Latest upstream release: v0.0.8
Current version/release in rawhide: 0.0.5-0.2.git97bc9a7.fc24
URL: https://github.com/opencontainers/runc

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 5 Upstream Release Monitoring 2016-02-10 19:18:23 EST
Failed to kick off scratch build.

spectool was unable to grab new sources

old source: runc-97bc9a7.tar.gz
old sha256: adbf92066ef88abba7537c6d96171e148cedf5a0c21cbc98b36bd4dc6f85008d

new source: ./runc-97bc9a7.tar.gz
new sha256: adbf92066ef88abba7537c6d96171e148cedf5a0c21cbc98b36bd4dc6f85008d
Comment 6 David Voit 2016-02-21 07:46 EST
Created attachment 1128994 [details]
opencontainer-specs for 0.3.0 specfile patch
Comment 7 David Voit 2016-02-21 07:46 EST
Created attachment 1128995 [details]
runc version 0.0.8 specfile patch
Comment 8 David Voit 2016-02-21 07:50:08 EST
Hi,

did some test builds for runc 0.0.8

https://copr.fedorainfracloud.org/coprs/davidvoit/runc/builds/

Should there be versioning for the go dependencies?

runc tests fails on copr but works on my machine here, the reason is that copr don't support xattributes and the tests don't skip then.

Regards,
David
Comment 9 Jan Chaloupka 2016-02-23 06:47:59 EST
rawhide:
segmentation fault, jcajka is working on it

f23:
> DEBUG util.py:393:  Error: No Package found for
> golang(github.com/docker/go-units)

Hmm, strange. The package is in overrides.

> DEBUG util.py:393:  Error: No Package found for
> golang(github.com/seccomp/libseccomp-golang)

Just made request for pushing to stable and to override.


> Should there be versioning for the go dependencies?

99% of deps has no releases just commits.
Comment 10 Jakub Čajka 2016-02-23 07:01:24 EST
(In reply to Jan Chaloupka from comment #9)
> rawhide:
> segmentation fault, jcajka is working on it
>

It is fixed. But rawhide have some issue with broken deps/API?:

https://kojipkgs.fedoraproject.org//work/tasks/6634/13096634/build.log

> 
> f23:
> > DEBUG util.py:393:  Error: No Package found for
> > golang(github.com/docker/go-units)
> 
> Hmm, strange. The package is in overrides.
> 
> > DEBUG util.py:393:  Error: No Package found for
> > golang(github.com/seccomp/libseccomp-golang)
> 
> Just made request for pushing to stable and to override.
> 
> 
> > Should there be versioning for the go dependencies?
> 
> 99% of deps has no releases just commits.
Comment 11 Jan Chaloupka 2016-02-23 07:06:54 EST
>> rawhide:
>> segmentation fault, jcajka is working on it
>>

> It is fixed. But rawhide have some issue with broken deps/API?:

> https://kojipkgs.fedoraproject.org//work/tasks/6634/13096634/build.log

Bodhi claims golang(github.com/docker/go-units) it is overrided.
Comment 12 David Voit 2016-02-23 09:53:03 EST
Oh sorry i did a rebuild on copr...

The segmentfault (rawhide) is caused by the go 1.6 mmap bug, which is now fixed (https://bugzilla.redhat.com/show_bug.cgi?id=1304591).

https://copr-be.cloud.fedoraproject.org/results/davidvoit/runc/fedora-rawhide-x86_64/00161383-runc/build.log.gz

Is the original log file, i was talking about, here you only have the xattr error.
Comment 13 Upstream Release Monitoring 2016-03-11 07:17:40 EST
Latest upstream release: v0.0.9
Current version/release in rawhide: 0.0.8-0.1.git1a124e9.fc25
URL: https://github.com/opencontainers/runc

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 14 Upstream Release Monitoring 2016-03-11 07:17:47 EST
Patching or scratch build for runc and version 0.0.8 FAILED.
See for details
Comment 15 Upstream Release Monitoring 2016-03-11 07:17:49 EST
Rebase helper failed.
See logs and attachments in this bugzilla global name 'os' is not defined
Comment 16 Upstream Release Monitoring 2016-03-11 07:17:51 EST
Patches were not touched. All were applied properly
Comment 17 Fedora Update System 2016-04-06 04:43:20 EDT
runc-0.0.9-0.2.git94dc520.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f45cdd71a
Comment 18 Fedora Update System 2016-04-06 04:43:26 EDT
runc-0.0.9-0.2.git94dc520.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-82665d7a6c
Comment 19 Fedora Update System 2016-04-06 13:53:12 EDT
runc-0.0.9-0.2.git94dc520.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f45cdd71a
Comment 20 Fedora Update System 2016-04-06 14:20:49 EDT
runc-0.0.9-0.2.git94dc520.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-82665d7a6c
Comment 21 Fedora Update System 2016-04-11 05:13:08 EDT
runc-0.0.9-0.2.git94dc520.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2016-04-12 09:12:32 EDT
runc-0.0.9-0.3.git94dc520.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5089717833
Comment 23 Fedora Update System 2016-04-13 05:26:20 EDT
runc-0.0.9-0.3.git94dc520.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5089717833
Comment 24 Fedora Update System 2016-04-20 15:20:42 EDT
runc-0.0.9-0.3.git94dc520.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.