Bug 1290960 - [GSS](6.4.z) EE, JPA & Weld subsystem adding javaee.api
[GSS](6.4.z) EE, JPA & Weld subsystem adding javaee.api
Status: CLOSED DEFERRED
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld (Show other bugs)
6.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: jboss-set
Matej Novotny
:
Depends On:
Blocks: 1202911 eap649-payload 1358822 1358913
  Show dependency treegraph
 
Reported: 2015-12-12 00:45 EST by Brad Maxwell
Modified: 2017-07-06 15:28 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 18:06:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker EAP6-225 Major Closed Move Java EE API Deps out of JavaEEDependencyProcessor and into subsystem DUPS 2018-06-06 16:40 EDT

  None (edit)
Description Brad Maxwell 2015-12-12 00:45:32 EST
It looks like this javaee.api got missed when EAP6-225 was done:

weld/src/main/java/org/jboss/as/weld/deployment/processors/WeldDependencyProcessor.java

     71         addDependency(moduleSpecification, moduleLoader, JAVAEE_API_ID);
Comment 2 Brad Maxwell 2015-12-12 01:09:36 EST
jpa/core/src/main/java/org/jboss/as/jpa/processor/JPADependencyProcessor.java

     91         addDependency(moduleSpecification, moduleLoader, deploymentUnit, JAVAEE_API_ID, JBOSS_AS_JPA_ID, JBOSS_AS_JPA_SPI_ID, JAVASSIST_ID);
Comment 3 Brad Maxwell 2015-12-12 02:03:38 EST
And: ee/src/main/java/org/jboss/as/ee/managedbean/processors/JavaEEDependencyProcessor.java
Comment 11 Mike McCune 2016-03-28 18:32:18 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 18 Brad Maxwell 2016-09-13 15:22:09 EDT
This change was backed out, as it caused regressions https://bugzilla.redhat.com/show_bug.cgi?id=1358822
Comment 20 Brad Maxwell 2017-06-27 18:06:03 EDT
Deferring to avoid possible issues in CP as this can affect current deployments

Note You need to log in before you can comment on or make changes to this bug.