Bug 1290964 - Can't browse backups generated by BackupPC, GUI crashes
Can't browse backups generated by BackupPC, GUI crashes
Status: CLOSED DUPLICATE of bug 1259481
Product: Fedora
Classification: Fedora
Component: BackupPC (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Benjamin Lefoul
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-12 01:33 EST by Stephen Dum
Modified: 2016-07-20 01:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 01:18:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Dum 2015-12-12 01:33:53 EST
Description of problem:
Gui Dies when trying to browse generated backups

Version-Release number of selected component (if applicable):
BackUP Version 3.3.1
Perl  5.22.0 x86_64

How reproducible:
see steps below

Steps to Reproduce:
1.Generate some backups
2.click on browse backups
3.click on one of the backup numbers to view the backed up tree

Actual results:
Perl throws an exception
Software error:

Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at
/usr/share/BackupPC/lib/BackupPC/CGI/Browse.pm line 68.

For help, please send mail to the webmaster (root@localhost), giving this
error message and the time and date of the error.
Software error:

[Fri Dec 11 21:49:38 2015] BackupPC_Admin.pl: Can't use 'defined(@array)'
(Maybe you should just omit the defined()?) at
/usr/share/BackupPC/lib/BackupPC/CGI/Browse.pm line 68.
Compilation failed in require at /usr/share/BackupPC/sbin/BackupPC_Admin.pl
line 108.



Expected results:
a backup tree to be displayed

Additional info:

Obviously no one used BackupPC since the version of perl was rolled.
Patch is obvious from the Error message.
Comment 1 Raman Gupta 2016-01-17 01:00:28 EST
See duplicate report (with patch) here:

https://bugzilla.redhat.com/show_bug.cgi?id=1259481
Comment 2 Fedora Admin XMLRPC Client 2016-06-28 12:31:47 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Benjamin Lefoul 2016-07-20 01:18:25 EDT

*** This bug has been marked as a duplicate of bug 1259481 ***

Note You need to log in before you can comment on or make changes to this bug.