Bug 129097 - With kudzu-1.1.75-1 a guaranteed hangup on reboot
With kudzu-1.1.75-1 a guaranteed hangup on reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-03 19:58 EDT by Michal Jaegermann
Modified: 2015-01-04 17:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 13:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-08-03 19:58:51 EDT
Description of problem:

On a cold boot kudzu does not create problems but I will
try to reboot then this invariably hangs in kudzu.  A machine
is dead to that extent that even trying sysrq key, which I
am turning on in a modified kudzu startup script, does not have
any effects.  Configuring it "SAFE" also has no effect.
It trying a manual run after after a reboot with kudzu service
turned off then one can see '/usr/sbin/kudzu -s -t 30' on
a screen nothing happens after that.

This was happening before often enough to be annoying but
now it is certain.

As a matter of fact the real culprit can be USB because
re-booting with 'nousb' in kernel parameters makes this hang
to go away. OTOH this makes USB clearly inaccessible.

Hardware: Tyan Tiger MP with 2 Athlon MP 1700+ processors.
Comment 1 Bill Nottingham 2004-08-04 01:01:12 EDT
I'm guessing this is a warm kernel reboot problem; there are other
reports of this.
Comment 2 Michal Jaegermann 2004-08-05 16:11:34 EDT
I am inclined right now to put that to "USB handling on this mobo"
bug.  This motherboard is known to have problems with USB and, as
a result of testing, some new OHCI Root Hub was added recently.
It could be too that kernel is not handling properly some weird USB
behaviour.  I cannot be sure.  If I will skip kudzu and will leave
"nousb" out of the picture then I will boot fine into level 3 but
then X will hang that machine without any traces anywhere.  Things are
usually fine from a cold boot even if kudzu will get stuck there too
on some infrequent occasions.

Hard for me to say anything about "other reports" Bill mentioned.
Comment 3 Dave Jones 2004-12-08 01:48:25 EST
any better with the current updates ?
Comment 4 Michal Jaegermann 2004-12-08 19:37:05 EST
> any better with the current updates ?

With 2.6.9-1.1020_FC4 turning on kudzu while 'nousb' was omitted
from boot parameters still kills my test box with an absolute
perfection.

But there is some progress.  Namely if I will leave kudzu out
of the picture then I can start X, which was impossible before,
and even a USB mouse does then work as well as a USB floppy (even
if the later did not mount itself; probably because it showed as
/dev/sda).
Comment 5 Dave Jones 2005-07-15 16:31:31 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.