Bug 1291002 - File is not demoted after self heal (split-brain)
File is not demoted after self heal (split-brain)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Joseph Elwin Fernandes
bugs@gluster.org
: Triaged, ZStream
Depends On: 1290401 1290975
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-12 11:16 EST by Joseph Elwin Fernandes
Modified: 2016-06-19 20:01 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290975
Environment:
Last Closed: 2016-02-14 02:25:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-13 03:10:02 EST
REVIEW: http://review.gluster.org/12959 (dht/rebalance: Use seperate return variable for destination cleanup) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-15 23:55:57 EST
COMMIT: http://review.gluster.org/12959 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit e35b9e272be54c3a2f9f9e7409053c6fb94707bb
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Sat Dec 12 15:21:06 2015 +0530

    dht/rebalance: Use seperate return variable for destination cleanup
    
    Use seperate local return variable for destination cleanup,
    without messing with the function return variable.
    
    Backport http://review.gluster.org/12956
    
    > Change-Id: Iaea9ed2927234fdb888aef7a31ec362090e98196
    > BUG: 1290975
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12956
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I2df0e29321647fd6eb1719eb3cb7d657fbed3793
    BUG: 1291002
    Reviewed-on: http://review.gluster.org/12959
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.