This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291037 - Upgrade from F22 -> F23 fails during "system-upgrade reboot" while erasing F22 packages
Upgrade from F22 -> F23 fails during "system-upgrade reboot" while erasing F2...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-12 21:19 EST by alweiner7
Modified: 2016-07-19 14:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:36:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf log that includes all runs of dnf-upgrade (8.85 MB, text/plain)
2015-12-12 21:19 EST, alweiner7
no flags Details

  None (edit)
Description alweiner7 2015-12-12 21:19:29 EST
Created attachment 1105266 [details]
dnf log that includes all runs of dnf-upgrade

Description of problem: "system-upgrade reboot" installs 3099 F23 packages and erases approx 800 F22 packages. It then fails while erasing more F22 packages with dnf exception: "The operation would result in removing the following protected packages: dnf, systemd". I've run the reboot multiple times. There were kernel paging failures during several of the runs which forced me to reboot.


Version-Release number of selected component (if applicable):


How reproducible: The failure is probably specific to one PC. I ran upgrade successfully on a second PC.


Steps to Reproduce:
1. run dnf-upgrade download --releasever=23 (reran until transaction test OK)
2. run dnf-upgrade reboot
3.

Actual results: reboot exited with dnf exception "the operation would result in removing the following protected packages: dnf, systemd". No initramfs or vmlinuz entries for F23 generated in /boot. 3099 F23 packages installed. Approx 800 F22 packages erased.


Expected results: All F22 packages erased and F23 initramfs and vmlinuz entries generated in /boot.


Additional info: I had to rerun download because of a leftover F20 package causing a dependency problem. I deleted the F20 package. I believe there were kernal paging errors that caused one or more of the upgrade-reboots to crash.
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-12-12 22:18:50 EST
What do you mean by "kernel paging errors"?
Comment 2 alweiner7 2015-12-13 20:23:06 EST
I get a daily logwatch report. (I run rsyslog as well as the systemd journal). Occasionally following a system crash which requires me to reboot, the next day's logwatch report shows something like "unable to handle kernel paging request".
Comment 3 Fedora End Of Life 2016-07-19 14:36:02 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.