Bug 1291048 - epel7 python-execnet fails to rebuild
epel7 python-execnet fails to rebuild
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-execnet (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: epel7aarch64
  Show dependency treegraph
 
Reported: 2015-12-13 01:25 EST by Yaakov Selkowitz
Modified: 2016-08-21 19:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-execnet-1.2.0-4.el7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-21 19:47:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-13 01:25:22 EST
python-execnet-1.2.0-4.el7 fails to rebuild due to test failures.  These tests also failed in Fedora since F21 and were therefore disabled.  Merging from at least commit edb2f7c fixes this for EPEL as well.
Comment 1 Thomas Moschny 2016-01-23 11:27:24 EST
Thanks for the info.

I've basically cherry-picked edb2f7c, see
http://pkgs.fedoraproject.org/cgit/rpms/python-execnet.git/commit/?h=epel7&id=8ee88a01
http://pkgs.fedoraproject.org/cgit/rpms/python-execnet.git/commit/?h=epel7&id=5342ba34

A scratch build succeeded:
http://koji.fedoraproject.org/koji/taskinfo?taskID=12663523

This does not warrant an update imho.
Comment 2 Yaakov Selkowitz 2016-07-07 18:59:38 EDT
A new build is required for the CentOS rebuild of EPEL for alternative arches.  However, this package can no longer be built in epel7 due to the removal of python-greenlet (see bug 1108884 comment 2) and the subsequent addition of ppc64 (for which rhel-extras is not available) to EPEL.  Leaving this open until this gets sorted out.
Comment 3 Fedora Update System 2016-08-04 13:29:49 EDT
python-execnet-1.2.0-4.el7.1 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-80c4473391
Comment 4 Fedora Update System 2016-08-05 18:18:16 EDT
python-execnet-1.2.0-4.el7.1 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-80c4473391
Comment 5 Fedora Update System 2016-08-21 19:46:59 EDT
python-execnet-1.2.0-4.el7.1 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.