Bug 1291054 - net-snmp leaks fds when on an SCTP enabled system
net-snmp leaks fds when on an SCTP enabled system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp (Show other bugs)
6.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
Dalibor Pospíšil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-13 03:33 EST by Martin Poole
Modified: 2016-05-10 21:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When a machine uses SCTP protocol and at the same time Net-SNMP daemon is running on the machine and is asked for statistics in SCTP-MIB, a file descriptor could be leaked in the SNMP daemon. Consequence: On busy systems, the daemon could reach maximum amount of opened file descriptors and crash. Fix: File descriptor leaks in SCTP-MIB were fixed. Result: The daemon does not crash.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:03:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2015-12-13 03:33:52 EST
Description of problem:

net-snmp is leaking file descriptors when run on an SCTP-enabled system until it runs out and effectively blocks.

Version-Release number of selected component (if applicable):

net-snmp-5.5-54.el6_7.1

Additional info:

Appears to need upstream patch

Commit: 65f2b7bcd4fe03906aa1a115ab60a89b8ae933d5 [65f2b7b]
Parents: 0e52e4f66d
Author: Jan Safranek <jsafranek@users.sourceforge.net>
Date: 19 January 2012 11:51:36 GMT

Close open files on error.
Comment 1 Jan Safranek 2015-12-15 08:48:35 EST
Reproducer:

1. Initiate a sctp connection, e.g. using sctp_darn:
server: sctp_darn -l -P 12345 -H 127.0.0.1
client: sctp_darn -h 127.0.0.1 -p 12345 -H 127.0.0.1 -P 12346 -s
(and send something from the client to the server, it's sort of nc-like tool)

Then, in a loop:
2. run: snmpwalk -v2c -c public localhost sctp
3. watch nr. of open file descriptors: ls -la  /proc/`pidof snmpd`/fd | wc -l

It should not grow.
Comment 7 errata-xmlrpc 2016-05-10 21:03:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0947.html

Note You need to log in before you can comment on or make changes to this bug.