Bug 1291063 - [ppc64le] Start vm with "Pass-Through Host CPU" enabled failed
[ppc64le] Start vm with "Pass-Through Host CPU" enabled failed
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
---
ppc64le Linux
medium Severity medium (vote)
: ovirt-3.6.7
: ---
Assigned To: Phillip Bailey
Artyom
: Triaged
Depends On:
Blocks: RHV4.1PPC RHEV4.0PPC
  Show dependency treegraph
 
Reported: 2015-12-13 06:29 EST by Artyom
Modified: 2016-07-25 10:18 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-04 08:32:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: exception+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
vdsm log (432.78 KB, text/plain)
2015-12-13 06:29 EST, Artyom
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54116 master MERGED core: Disable Pass-Through Host CPU for PPC Arch 2016-04-21 04:41 EDT
oVirt gerrit 56483 ovirt-engine-3.6 MERGED core: Disable Pass-Through Host CPU for PPC Arch 2016-05-04 07:43 EDT
oVirt gerrit 57183 ovirt-engine-3.6.6 MERGED core: Disable Pass-Through Host CPU for PPC Arch 2016-05-08 12:39 EDT

  None (edit)
Description Artyom 2015-12-13 06:29:13 EST
Created attachment 1105288 [details]
vdsm log

Description of problem:
Start vm with "Pass-Through Host CPU" enabled failed with traceback under vdsm log:
Thread-22434::ERROR::2015-12-13 05:03:58,956::vm::758::virt.vm::(_startUnderlyingVm) vmId=`3f3cd31f-b2de-4341-b36b-6b63898935f0`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/vm.py", line 702, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/virt/vm.py", line 1889, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib/python2.7/site-packages/vdsm/libvirtconnection.py", line 124, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3611, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: internal error: Unknown CPU model hostPassthrough


Version-Release number of selected component (if applicable):
vdsm-4.17.13-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create vm and pin it to host
2. Enable "Pass-Through Host CPU" option on vm
3. Start vm

Actual results:
vm failed to start with above error

Expected results:
vm succeed to start and inherit cpu flags from host cpu

Additional info:
looks like instead of mode we send hostPassthrough to cpu model
  <cpu>
                <model>hostPassthrough</model>
                <topology cores="1" sockets="1" threads="1"/>
        </cpu>
Comment 1 Artyom 2015-12-13 09:39:00 EST
My mistake correct version of vdsm where it happen:
vdsm-4.17.12-1.el7ev.noarch
Comment 2 Michal Skrivanek 2015-12-13 11:24:30 EST
POWER doesn't have a concept of CPU host passthrough really. The checkbox should probably be disabled.
Decreasing Severity since this is not supposed to work
Comment 3 Mike McCune 2016-03-28 19:17:33 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Sandro Bonazzola 2016-05-06 16:56:32 EDT
Looks like referenced pathces are not in 3.6.6 rc2 code, can you check if this has to be moved to QE or to POST?
Comment 5 Phillip Bailey 2016-05-08 07:05:23 EDT
Ported to 3.6.6 branch.
Comment 6 Sandro Bonazzola 2016-05-19 03:35:52 EDT
Is this included in the 3.6.6 build? If so, please move to QE, otherwise re-target to 3.6.7.
Comment 8 Artyom 2016-05-24 05:08:29 EDT
Checked on rhevm-3.6.6.2-0.1.el6.noarch
Bug still exist
Comment 11 Artyom 2016-06-02 03:39:18 EDT
I can see that bug solved under rhevm-3.6.7-0.1.el6.noarch, so you can move it ON_QA and I will Verify it
Comment 12 Artyom 2016-06-06 10:04:54 EDT
Verified on rhevm-3.6.7-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.