Bug 129110 - Evolution should recover better from a crash - import data
Summary: Evolution should recover better from a crash - import data
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-04 04:23 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 00:32:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Gyurdiev 2004-08-04 04:23:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
Evolution went and erased my settings, so now I'm importing .ics files
back into evolution from its own folder. What's wrong with this
picture? I don't know what the problem is, but I am absolutely sure
that there is a problem, because I shouldn't have to do that. 

Evolution should recover from whatever's wrong and import the .ics
files in its own .evolution folder.

If not at least the importer should support importing from evolution,
because it didn't detect anything, and I had to import single file 20
times in a row from a hidden folder (not viewable on the import menu).








Version-Release number of selected component (if applicable):
evolution-1.5.91-1

How reproducible:
Always

Steps to Reproduce:
1. See summary
    

Additional info:

Comment 1 Ivan Gyurdiev 2004-08-04 05:22:35 UTC
So it seems my tasks used to be stored in:
.evolution/tasks/local/OnThisComputer/*

and are now stored in

.evolution/tasks/local/*

If that is the case, then I guess this bug is about asking for the
following 2 things:

1) When locations and things like this change, the user's data should
be migrated automatically

2) Perhaps the importer should intelligently find all files in all
possible locations of old versions of Evolution, similarly to the way
it finds Netscape and other data.
====================

By the way I can't figure out how to get back my contacts back at all.
I have a bunch of address books as follows:

.evolution/addressbook/local/system/(db, summary)
.evolution/addressbook/local/OnThisComputer/(3 more folders like system)

and the only contacts I see are the ones in system.
I tried moving the 3 other folders up one level like tasks seem to
work, but it's not helping, so I guess I'd like to see one more feature:

3) A way to import .db contacts files 

Comment 2 Andrew Farris 2004-10-17 11:25:00 UTC
RE item 3)
I have also lost contacts through updates.  I had several separate 'On this
computer' contact lists, and now have only the Personal list (which still
contains my contacts for that list).  I'm not sure when these disappeared
actually, because for the bulk of my use I do not use the other lists.

The .db files are still there, identical directories from my previous backup (at
a time I knew they were usable), but evolution isn't grabbing these lists when
it starts.  I guess this needs to go upstream, I don't see anything regarding
this specifically, the berkeley database files should be read by evolution...
not require a specific import anyway.

Comment 3 Ivan Gyurdiev 2004-11-25 00:32:05 UTC
This was an RFE, and not very specific.
Doesn't seem likely to get fixed, at least not here.





Note You need to log in before you can comment on or make changes to this bug.