This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291140 - ipa client should configure kpasswd_server directive in krb5.conf
ipa client should configure kpasswd_server directive in krb5.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 01:05 EST by Abhijeet Kasurde
Modified: 2016-11-04 01:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:42:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (2.43 KB, text/plain)
2016-09-02 03:02 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-12-14 01:05:27 EST
Description of problem:

While user configures client using IPA client, it edits krb5.conf for kdc, master_kdc and admin_server. It is good to configure additional 
'kpasswd_server' configuration in krb5.conf. This helps in configuring KdcProxy in IPA client.


Version-Release number of selected component (if applicable):
ipa-client-4.2.0-15.el7_2.3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install 'ipa-client-install'
2. Observe /etc/krb5.conf

Actual results:
kpasswd_server is missing.

Expected results:
kpasswd_server is configured using ipa-client-install. This directive will not harm but could have avoided BZ 1290398

Additional info:
http://web.mit.edu/kerberos/krb5-1.11/doc/admin/conf_files/krb5_conf.html
https://github.com/npmccallum/kdcproxy#configuring-a-client-for-kdcproxy
Comment 2 Petr Vobornik 2015-12-14 06:13:03 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5547
Comment 3 Petr Vobornik 2016-01-25 17:57:51 EST
Fixed upstream:

master:
    e381d763fa99df80c326b7fa63469d3380b7f08e Added kpasswd_server directive in client krb5.conf
Comment 4 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Abhijeet Kasurde 2016-09-02 03:02 EDT
Created attachment 1197054 [details]
console.log

Verified using IPA Version ::
ipa-server-4.4.0-8.el7.x86_64

Marking BZ as verified.
Comment 8 errata-xmlrpc 2016-11-04 01:42:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.