Bug 1291154 - Miss configuring the '--log-driver' and '--log-opt' in docker configuration
Miss configuring the '--log-driver' and '--log-opt' in docker configuration
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 02:16 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-12-14 02:16:39 EST
Description of problem:
Miss configuring the '--log-driver' and '--log-opt' in docker configuration

Version-Release number of selected component (if applicable):
https://github.com/sdodson/openshift-ansible containers

How reproducible:
Always


Steps to Reproduce:

1. Install container env with specified 'docker log options'
export docker_log_options=tag="mailer"
export docker_log_driver=syslog
ansible-playbook -i hosts_test openshift-ansible/playbooks/byo/config.yml -v

2. check the docker configuration
vim /etc/sysconfig/docker
OPTIONS='--insecure-registry=172.30.0.0/16 --selinux-enabled   '




Actual results:
There is no configuration on '--log-driver' and '--log-opts'

Expected results:
Miss configuring '--log-driver' and '--log-opts'

Additional info:
Comment 1 Scott Dodson 2015-12-15 15:35:47 EST
Thanks, should be fixed now. Please re-pull the containers branch.
Comment 2 Ma xiaoqiang 2015-12-17 20:45:42 EST
Get the expected result.

vim /etc/sysconfig/docker
OPTIONS='--insecure-registry=172.30.0.0/16 --selinux-enabled  --log-driver json-file      --log-opt max-size=10M   '
Comment 4 errata-xmlrpc 2016-01-27 14:43:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.