Bug 1291162 - Uninstall playbook should remove the etcd images
Uninstall playbook should remove the etcd images
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 03:06 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-12-14 03:06:07 EST
Uninstall playbook should remove the etcd images, if re-installed, user can not get the latest image.

Version-Release number of selected component (if applicable):
https://github.com/sdodson/openshift-ansible containers

How reproducible:
Always


Steps to Reproduce:

1. Install a containerized env with external etcd on atomic
vim hosts_test
<--snip-->
[etcd]
10.66.79.156
[nodes]
<--snip-->

2. uninstall the env
ansible-playbook -i hosts_test openshift-ansible/playbooks/adhoc/uninstall.yml 


Actual results:
#docker images|grep etcd
virt-openshift-05.lab.eng.nay.redhat.com:5000/rhel7/etcd                                        latest              a15079cec631        5 days ago          233.6 MB
registry.access.redhat.com/rhel7/etcd                                                           latest              a15079cec631        5 days ago          233.6 MB

Expected results:
Should delete the etcd image

Additional info:
Comment 1 Scott Dodson 2015-12-15 14:09:18 EST
I've added etcd to the list of images we remove during uninstall.
Comment 2 Scott Dodson 2015-12-15 15:35:58 EST
Please re-pull the containers branch to test again.
Comment 3 Ma xiaoqiang 2015-12-17 21:11:26 EST
The etcd images have been deleted.
Comment 5 errata-xmlrpc 2016-01-27 14:43:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.