Bug 1291177 - [RFE] Display disk content type in the GUI, and allow searching/filtering according to it
[RFE] Display disk content type in the GUI, and allow searching/filtering acc...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
4.0.0
Unspecified Unspecified
low Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Tal Nisan
Raz Tamir
: FutureFeature
Depends On: ovirt_refactor_disk_class_hierarchy
Blocks: 1505352
  Show dependency treegraph
 
Reported: 2015-12-14 04:02 EST by Allon Mureinik
Modified: 2017-12-20 05:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
In the Administration Portal, on the "Disks" tab, disks can be filtered by content type.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:59:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
ratamir: testing_plan_complete-
ylavi: planning_ack+
amureini: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 74905 master MERGED core: Add a content type to disks 2017-04-04 04:23 EDT

  None (edit)
Description Allon Mureinik 2015-12-14 04:02:21 EST
The disk representation in the backend already contains a content-type enum with two options (DATA and OVF_STORE), and more will be added in the future.

These options should be displayed in the GUI (alongside the disk type, probably), and should be available for filtering and searching.
Comment 1 Yaniv Kaul 2017-10-15 04:46:21 EDT
Any updates? I assume POST is because there's one patch posted, but the RFE isn't done yet? Should it be set back to ASSIGNED or ON_DEV?
Comment 2 Tal Nisan 2017-10-15 05:43:12 EDT
Actually the original patch and a large series of other patches are merged long ago, no idea why it wasn't moved to MODIFIED
Comment 3 Raz Tamir 2017-10-15 05:49:31 EDT
Tal,

Can you please provide more information on this RFE?
Is there any feature page for it?

I want to ensure we are not miss anything in our tests
Comment 4 Tal Nisan 2017-10-15 08:25:10 EDT
No, basically the only difference is that now in the Disks tab you have another filtering option which is by content type
Comment 6 Raz Tamir 2017-10-26 04:00:09 EDT
Verified on ovirt-engine-4.2.0-0.0.master.20171023193344.gitc3b23f6.el7.centos

Few bugs (not severe) were opened:
- https://bugzilla.redhat.com/show_bug.cgi?id=1506468
- https://bugzilla.redhat.com/show_bug.cgi?id=1506473
Comment 7 Sandro Bonazzola 2017-12-20 05:59:44 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.